aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2024-10-24 18:54:32 +0200
committerUlrich Müller <ulm@gentoo.org>2024-11-09 07:56:28 +0100
commit906455c6a2b0f0dfd12efc1e44d51f2d469c3442 (patch)
tree2e9680016bf33c0f10d1ed61b066664a290ff953 /Makefile
parentdevbook.xsl: Test for include instead of contentsTree in dropdown menu (diff)
downloaddevmanual-906455c6a2b0f0dfd12efc1e44d51f2d469c3442.tar.gz
devmanual-906455c6a2b0f0dfd12efc1e44d51f2d469c3442.tar.bz2
devmanual-906455c6a2b0f0dfd12efc1e44d51f2d469c3442.zip
Rename the document element from "guide" to "devbook"
The "guide" document element is ambiguous with the previously used GuideXML format. Now that DevBook XML has a schema, this confuses Emacs nXML mode (which uses the document element to locate a schema), e.g. when visiting old GuideXML documentation files. Signed-off-by: Ulrich Müller <ulm@gentoo.org>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index c377d5d..ff9e852 100644
--- a/Makefile
+++ b/Makefile
@@ -87,9 +87,9 @@ install: all
validate: devbook.rng
@xmllint --noout --quiet --relaxng $< $(XMLS)
- @# Check if /guide/@self agrees with the document path
+ @# Check if /devbook/@self agrees with the document path
@for file in $(XMLS); do \
- self=$$(xmllint --quiet --xpath 'string(/guide/@self)' $${file}); \
+ self=$$(xmllint --quiet --xpath 'string(/devbook/@self)' $${file}); \
if test "$${self}text.xml" != "$${file#./}"; then \
echo "$${file}: bad self attribute '$${self}'"; exit 1; \
fi; \