aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'catalyst/livecd/2008.0')
-rwxr-xr-xcatalyst/livecd/2008.0/overlay/usr/sbin/cluster-setup13
-rw-r--r--catalyst/livecd/2008.0/specs/amd64/livecd-stage1.spec2
2 files changed, 13 insertions, 2 deletions
diff --git a/catalyst/livecd/2008.0/overlay/usr/sbin/cluster-setup b/catalyst/livecd/2008.0/overlay/usr/sbin/cluster-setup
index 8d95ca8..233b89e 100755
--- a/catalyst/livecd/2008.0/overlay/usr/sbin/cluster-setup
+++ b/catalyst/livecd/2008.0/overlay/usr/sbin/cluster-setup
@@ -160,7 +160,11 @@ portageq envvar USE | grep -q pbs
if [[ $? == 0 ]]; then
einfo "Setting up torque on $HOSTNAME and in $NFSROOT"
- emerge --config =sys-cluster/torque-2.3.3
+ USE=server emerge --config =sys-cluster/torque-2.3.3
+ # if mom is not started on the master node, listing it in nodes doesn't hurt it and
+ # makes sure the file exists
+ echo $(hostname) >> $PBS_SERVER_HOME/server_priv/nodes
+ /etc/init.d/pbs_server start
USE=-server ROOT=$NFSROOT emerge --config =sys-cluster/torque-2.3.3
fi
@@ -171,3 +175,10 @@ einfo "Setting up auth on the $NFSROOT"
USE=-authmaster ROOT="$NFSROOT" emerge --config =net-nds/ldap-auth-0.1
[[ $? == 0 ]] && einfo "Once you have nodes going, restart Torque (pbs_server)"
+if [[ $1 == "--test" ]]; then
+ echo 'Using --test implies the following:
+- root password is "test" and can log on (passwordless) onto nodes !!!!
+- ldap admin password is "default" !!!!(again)
+- eth1 is the cluster\'s NIC and is set to 10.0.0.1/24
+- eth0 is the public nic
+- all defaults in .config files get used'
diff --git a/catalyst/livecd/2008.0/specs/amd64/livecd-stage1.spec b/catalyst/livecd/2008.0/specs/amd64/livecd-stage1.spec
index 17ab415..fa63839 100644
--- a/catalyst/livecd/2008.0/specs/amd64/livecd-stage1.spec
+++ b/catalyst/livecd/2008.0/specs/amd64/livecd-stage1.spec
@@ -40,7 +40,7 @@ livecd/use:
tk
livecd/packages:
- app-accessibility/brltty
+# app-accessibility/brltty
app-admin/hddtemp
app-admin/ide-smart
app-admin/logrotate