aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rwxr-xr-xswitchshapshot.sh13
1 files changed, 13 insertions, 0 deletions
diff --git a/switchshapshot.sh b/switchshapshot.sh
new file mode 100755
index 0000000..9832641
--- /dev/null
+++ b/switchshapshot.sh
@@ -0,0 +1,13 @@
+#!/bin/bash
+
+if [[ $# != 1 ]]; then
+ echo "Specify snapshot to switch to, ie:
+$0 20080806"
+ exit 1
+fi
+
+for I in catalyst/livecd/2008.0/specs/amd64 catalyst/nfsroot/2008.0/specs/amd64
+do
+ sed -i -e "s#snapshot:.*#snapshot: $1#" ${I}/*.spec
+done
+