summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Jolly <kangie@gentoo.org>2024-03-21 07:45:00 +1000
committerMatt Jolly <kangie@gentoo.org>2024-03-21 07:45:00 +1000
commit3b0f8cfc4a3d2e3344be2786a6ea9c255c43f8ee (patch)
tree17c4283a3b1e3a012e6881a86472a8180bc95e52
parentAdd script to generate new gn version and tarball from git (diff)
downloadchromium-tools-3b0f8cfc4a3d2e3344be2786a6ea9c255c43f8ee.tar.gz
chromium-tools-3b0f8cfc4a3d2e3344be2786a6ea9c255c43f8ee.tar.bz2
chromium-tools-3b0f8cfc4a3d2e3344be2786a6ea9c255c43f8ee.zip
New script: get_chromium_toolchain_strings.sh
Just does some awks and seds to enable the automated update of google toolchain information within / from the specified ebuild Signed-off-by: Matt Jolly <kangie@gentoo.org>
-rwxr-xr-xget_chromium_toolchain_strings.sh70
1 files changed, 70 insertions, 0 deletions
diff --git a/get_chromium_toolchain_strings.sh b/get_chromium_toolchain_strings.sh
new file mode 100755
index 0000000..483d66f
--- /dev/null
+++ b/get_chromium_toolchain_strings.sh
@@ -0,0 +1,70 @@
+#!/bin/bash
+
+# This script extracts version information from Chromium sources by way of a Gentoo ebuild
+# then plugs the version information into the ebuild file. This is useful for updating the
+# toolchain versions in the ebuild file when a new (major) version of Chromium is released.
+
+# Usage: get_chromium_toolchain_strings.sh <ebuild_file>
+# <ebuild_file>: The path to the Chromium ebuild file
+
+# Extract the version string from an ebuild
+get_version() {
+ local filename="$1"
+ [[ -z "$filename" ]] && return 1 # Check for empty filename
+ local version_match="${filename##*-}"; # Extract everything after the last hyphen
+ version_match="${version_match%.*}" # Remove extension (.ebuild)
+ echo "$version_match"
+}
+
+# Display script usage
+usage() {
+ echo "Usage: get_chromium_toolchain_strings.sh <ebuild_file>"
+ echo " <ebuild_file>: The path to the Chromium ebuild file"
+}
+
+# Get the ebuild filename as the first argument
+ebuild_file="$1"
+
+# Check for missing argument
+if [[ -z "$ebuild_file" ]]; then
+ echo "Error: Please provide an ebuild filename as an argument."
+ usage
+ exit 1
+fi
+
+# Extract version from filename
+version="$(get_version "$ebuild_file")"
+
+# Check if version extraction failed (function return code)
+if [[ $? -ne 0 ]]; then
+ echo "Error: Could not extract version from filename."
+ exit 1
+fi
+
+# Construct S string based on version
+# Bad luck if you don't use /var/tmp/portage, I guess.
+S="/var/tmp/portage/www-client/chromium-${version}/work/chromium-${version}/"
+
+# Run ebuild with clean and unpack options
+ebuild "$ebuild_file" clean unpack
+
+# No secret sauce here - it's just simpler to set the field separator to a single quote
+# and then extract the final character from the sub-revision field.
+# This is a bit of a hack, but it works for now - I haven't see upstream go past the
+# 9th sub-revision yet!
+
+llvm_version=$(awk -F"'" '
+/CLANG_REVISION =/ { revision = $2 }
+/CLANG_SUB_REVISION =/ { printf("%s-%d\n", revision, substr($1, length($1), 1)) }
+' "${S}/tools/clang/scripts/update.py")
+
+rust_version=$(awk -F"'" '
+/RUST_REVISION =/ { revision = $2 }
+/RUST_SUB_REVISION =/ { printf("%s-%d\n", revision, substr($1, length($1), 1)) }
+' "${S}/tools/rust/update_rust.py")
+
+# Substitute versions into ebuild (assuming specific locations)
+sed -i "s/GOOGLE_CLANG_VER=.*/GOOGLE_CLANG_VER=${llvm_version}/" "$ebuild_file"
+sed -i "s/GOOGLE_RUST_VER=.*/GOOGLE_RUST_VER=${rust_version}/" "$ebuild_file"
+
+echo "Successfully substituted versions into $ebuild_file"