summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrent Baude <ranger@gentoo.org>2007-04-12 15:13:08 +0000
committerBrent Baude <ranger@gentoo.org>2007-04-12 15:13:08 +0000
commit7c919dd4be454066ec5d31d9c5c265434c9a3f56 (patch)
tree81d9d3fa48cb92cf3b23e08cd0f766df6347d6b5
parentAdding a petitboot binary build (diff)
downloadcell-7c919dd4be454066ec5d31d9c5c265434c9a3f56.tar.gz
cell-7c919dd4be454066ec5d31d9c5c265434c9a3f56.tar.bz2
cell-7c919dd4be454066ec5d31d9c5c265434c9a3f56.zip
adding ps3pf_utils
svn path=/; revision=7
-rw-r--r--app-misc/ps3pf_utils/Manifest8
-rw-r--r--app-misc/ps3pf_utils/files/digest-ps3pf_utils-1.0.93
-rw-r--r--app-misc/ps3pf_utils/ps3pf_utils-1.0.9.ebuild29
3 files changed, 40 insertions, 0 deletions
diff --git a/app-misc/ps3pf_utils/Manifest b/app-misc/ps3pf_utils/Manifest
new file mode 100644
index 0000000..26db4ea
--- /dev/null
+++ b/app-misc/ps3pf_utils/Manifest
@@ -0,0 +1,8 @@
+DIST ps3pf_utils-1.0.9.tar.bz2 5345 RMD160 164b484cda5cf41d8ed3a6d2851b93804905abe4 SHA1 557bc835fbd558b24ab7b9eee78b6d6b9baf408d SHA256 52a379779d5b94f2d9e532e128946efa56e865eac522cb1b6199f6da882df527
+EBUILD ps3pf_utils-1.0.9.ebuild 771 RMD160 b7b7945658238268aa4da29f00e006f0202fa95e SHA1 7554044575c7099733d72562576c84c4b5f520d7 SHA256 8c4169ca3612304de9da20fc17107d5cfe4508c3e74cf69a7c6029ca0b946c05
+MD5 440b66fbad85c85c8fd97daa882771bc ps3pf_utils-1.0.9.ebuild 771
+RMD160 b7b7945658238268aa4da29f00e006f0202fa95e ps3pf_utils-1.0.9.ebuild 771
+SHA256 8c4169ca3612304de9da20fc17107d5cfe4508c3e74cf69a7c6029ca0b946c05 ps3pf_utils-1.0.9.ebuild 771
+MD5 6e1c5a5b08be521544131d90db583851 files/digest-ps3pf_utils-1.0.9 250
+RMD160 1518b1cd03ecf4ee1b50989d90dcb4c04c41baba files/digest-ps3pf_utils-1.0.9 250
+SHA256 b5fa29913d26f405f3b170d8c96b9f03030d0a4931e6addb74da2d4ca9db0003 files/digest-ps3pf_utils-1.0.9 250
diff --git a/app-misc/ps3pf_utils/files/digest-ps3pf_utils-1.0.9 b/app-misc/ps3pf_utils/files/digest-ps3pf_utils-1.0.9
new file mode 100644
index 0000000..6ef2ef6
--- /dev/null
+++ b/app-misc/ps3pf_utils/files/digest-ps3pf_utils-1.0.9
@@ -0,0 +1,3 @@
+MD5 5fc8c2e946932f39b6d3c21c7668beb1 ps3pf_utils-1.0.9.tar.bz2 5345
+RMD160 164b484cda5cf41d8ed3a6d2851b93804905abe4 ps3pf_utils-1.0.9.tar.bz2 5345
+SHA256 52a379779d5b94f2d9e532e128946efa56e865eac522cb1b6199f6da882df527 ps3pf_utils-1.0.9.tar.bz2 5345
diff --git a/app-misc/ps3pf_utils/ps3pf_utils-1.0.9.ebuild b/app-misc/ps3pf_utils/ps3pf_utils-1.0.9.ebuild
new file mode 100644
index 0000000..09ad453
--- /dev/null
+++ b/app-misc/ps3pf_utils/ps3pf_utils-1.0.9.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit flag-o-matic
+
+DESCRIPTION="Utilities to set the ps3 specific features"
+HOMEPAGE="http://www.playstation.com/ps3-openplatform/index.html"
+SRC_URI="http://www.powerdeveloper.org/files/Cell/SourceCD/${P}.tar.bz2
+ http://dev.gentoo.org/~lu_zero/distfiles/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~ppc ~ppc64"
+IUSE=""
+
+# fixme: depend on a version of sys-kernel/linux-headers that supports ps3
+
+DEPEND=""
+RDEPEND=""
+
+src_compile() {
+ append-flags -I/usr/src/linux/include/
+ emake CFLAGS="${CFLAGS}" || die "compile failed, do you have up to date kernel sources?"
+}
+
+src_install() {
+ emake DESTDIR=${D} install || die "install failed"
+}