summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-vcs/git-cola/git-cola-9999.ebuild')
-rw-r--r--dev-vcs/git-cola/git-cola-9999.ebuild95
1 files changed, 0 insertions, 95 deletions
diff --git a/dev-vcs/git-cola/git-cola-9999.ebuild b/dev-vcs/git-cola/git-cola-9999.ebuild
deleted file mode 100644
index 526fa64..0000000
--- a/dev-vcs/git-cola/git-cola-9999.ebuild
+++ /dev/null
@@ -1,95 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 python3_{3,4,5} )
-DISTUTILS_SINGLE_IMPL=true
-
-inherit distutils-r1 git-r3 readme.gentoo-r1 virtualx
-
-DESCRIPTION="The highly caffeinated git GUI"
-HOMEPAGE="http://git-cola.github.io/"
-SRC_URI=""
-EGIT_REPO_URI="git://github.com/git-cola/git-cola.git"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS=""
-IUSE="doc test"
-
-RDEPEND="
- dev-python/pyinotify[${PYTHON_USEDEP}]
- dev-python/send2trash[${PYTHON_USEDEP}]
- dev-python/PyQt4[${PYTHON_USEDEP}]
- dev-vcs/git"
-DEPEND="${RDEPEND}
- sys-devel/gettext
- doc? (
- dev-python/sphinx[${PYTHON_USEDEP}]
- python_targets_python2_7? ( dev-python/sphinxtogithub[$(python_gen_usedep 'python2*')] )
- )
- test? ( dev-python/nose[${PYTHON_USEDEP}] )
-"
-
-python_prepare_all() {
- rm share/git-cola/bin/*askpass* || die
-
- # remove broken tests
- rm test/i18n_test.py || die
-
- # don't install docs into wrong location
- sed -i -e '/doc/d' setup.py || die
-
- # fix doc directory reference
- sed -i \
- -e "s/'doc', 'git-cola'/'doc', '${PF}'/" \
- cola/resources.py || die
-
- # fix ssh-askpass directory reference
- sed -i -e 's/resources\.share/resources\.prefix/' cola/app.py || die
-
- distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
- cd share/doc/${PN}/ || die
- if use doc; then
- emake all
- else
- sed \
- -e '/^install:/s:install-html::g' \
- -e '/^install:/s:install-man::g' \
- -i Makefile || die
- fi
-}
-
-python_test() {
- PYTHONPATH="${S}:${S}/build/lib:${PYTHONPATH}" \
- LC_ALL="C" \
- GIT_COLA_NO_HISTORY=True \
- virtx nosetests \
- --verbose --with-id --with-doctest \
- --exclude=sphinxtogithub
-}
-
-python_install_all() {
- cd share/doc/${PN}/ || die
- emake \
- DESTDIR="${D}" \
- docdir="${EPREFIX}/usr/share/doc/${PF}" \
- prefix="${EPREFIX}/usr" \
- install
-
- python_fix_shebang "${ED}/usr/share/git-cola/bin/git-xbase" "${ED}"/usr/bin/git-cola
- python_optimize "${ED}/usr/share/git-cola/lib/cola"
-
- use doc || HTML_DOCS=( "${FILESDIR}"/index.html )
-
- distutils-r1_python_install_all
- readme.gentoo_create_doc
-}
-
-pkg_postinst() {
- readme.gentoo_print_elog
-}