summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sebastian@pipping.org>2014-08-17 23:13:58 +0200
committerSebastian Pipping <sebastian@pipping.org>2014-08-18 00:26:24 +0200
commit873ca8f1e7585b5ef38d4d6c63c8c4c09b727cb8 (patch)
treef77f7e511563418bf6b7ea9088ea3ffb880b45ba /app-emulation
parentmedia-fonts/VeraSansYuanTi: 0 (diff)
downloadbetagarden-873ca8f1e7585b5ef38d4d6c63c8c4c09b727cb8.tar.gz
betagarden-873ca8f1e7585b5ef38d4d6c63c8c4c09b727cb8.tar.bz2
betagarden-873ca8f1e7585b5ef38d4d6c63c8c4c09b727cb8.zip
app-emulation/wineloc: 0.41
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/wineloc/Manifest1
-rw-r--r--app-emulation/wineloc/wineloc-0.41.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/app-emulation/wineloc/Manifest b/app-emulation/wineloc/Manifest
new file mode 100644
index 0000000..97c3bad
--- /dev/null
+++ b/app-emulation/wineloc/Manifest
@@ -0,0 +1 @@
+DIST wineloc-0.41.tar.gz 18542 SHA256 640b551f9fe2374d8ad6f6b6e27692decc57314a612e3362a95388c2fc41c01f SHA512 e25707921f2381d90ce53accb3a82424c775bf7091d2e7d50683a72402792b6729d3bc8e21450228aa4ffe75a4cd35dffe50a8d01a4b453987c032238e63dfbe WHIRLPOOL 262da22605e54663035d6139305382b32ec67eef37603a09d5d156fdc114f4d3f60a703931c87b2a1a4e9468940c6ab4834e1648025c12dcd550fd25e4991078
diff --git a/app-emulation/wineloc/wineloc-0.41.ebuild b/app-emulation/wineloc/wineloc-0.41.ebuild
new file mode 100644
index 0000000..713801a
--- /dev/null
+++ b/app-emulation/wineloc/wineloc-0.41.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="5"
+
+DESCRIPTION="CJK Launcher for Wine (cli)"
+HOMEPAGE="https://bitbucket.org/dsobodash/winelocale"
+SRC_URI="http://files.sobodash.com/software/winelocale/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="app-emulation/wine
+ media-fonts/VeraSansYuanTi"
+
+src_prepare() {
+ sed -i 's|WLOCSHARE=/usr/local/share/wineloc|WLOCSHARE=/usr/share/wineloc|' \
+ share/wineloc || die
+}
+
+src_install() {
+ insinto /usr/share/${PN}
+ doins -r share/patches || die
+
+ dodoc CHANGELOG INSTALL || die
+
+ dobin share/wineloc || die
+
+ ewarn 'For Chinese, be sure to enable these locales in /etc/locale.gen:'
+ ewarn ' zh_CN.UTF-8 UTF-8'
+ ewarn ' zh_TW.UTF-8 UTF-8'
+ ewarn ' zh_CN GB2312'
+ ewarn ' zh_CN.GBK GBK'
+ ewarn ' zh_CN.GB18030 GB18030'
+ ewarn ' zh_TW BIG5'
+ ewarn ''
+ ewarn 'Do not forget to run "sudo locale-gen" to propagate changes.'
+}