summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorwiktor w brodlo <wiktor@brodlo.net>2011-06-14 12:30:58 +0000
committerwiktor w brodlo <wiktor@brodlo.net>2011-06-14 12:30:58 +0000
commit493c03b2e32a76e661b2508a8ded3df2dda2c6b7 (patch)
tree0f8d6e2f8593b4db96871a4bcac1f2c3147e1fe2
parentlibuser sandbox violation fix (diff)
downloadanaconda-overlay-493c03b2e32a76e661b2508a8ded3df2dda2c6b7.tar.gz
anaconda-overlay-493c03b2e32a76e661b2508a8ded3df2dda2c6b7.tar.bz2
anaconda-overlay-493c03b2e32a76e661b2508a8ded3df2dda2c6b7.zip
new package: app-misc/sabayon-version
-rw-r--r--app-misc/sabayon-version/Manifest2
-rw-r--r--app-misc/sabayon-version/sabayon-version-5-r5.ebuild54
-rw-r--r--app-misc/sabayon-version/sabayon-version-6.ebuild54
3 files changed, 110 insertions, 0 deletions
diff --git a/app-misc/sabayon-version/Manifest b/app-misc/sabayon-version/Manifest
new file mode 100644
index 0000000..4db75b2
--- /dev/null
+++ b/app-misc/sabayon-version/Manifest
@@ -0,0 +1,2 @@
+EBUILD sabayon-version-5-r5.ebuild 1300 RMD160 f744ab8329e3b5b0e2e1848cf7dc3d7f88b54efd SHA1 d2ade1dfdcf13a3f026211591f44dad1f961d2b2 SHA256 30b1e95a156bc93af26bd60778fd673d178a9ff8070b93033c78b4f1793bc2a3
+EBUILD sabayon-version-6.ebuild 1300 RMD160 f744ab8329e3b5b0e2e1848cf7dc3d7f88b54efd SHA1 d2ade1dfdcf13a3f026211591f44dad1f961d2b2 SHA256 30b1e95a156bc93af26bd60778fd673d178a9ff8070b93033c78b4f1793bc2a3
diff --git a/app-misc/sabayon-version/sabayon-version-5-r5.ebuild b/app-misc/sabayon-version/sabayon-version-5-r5.ebuild
new file mode 100644
index 0000000..3c117e2
--- /dev/null
+++ b/app-misc/sabayon-version/sabayon-version-5-r5.ebuild
@@ -0,0 +1,54 @@
+# Copyright 2004-2011 Sabayon Linux
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=3
+
+DESCRIPTION="Sabayon System Release virtual package"
+HOMEPAGE="http://www.sabayon.org/"
+SRC_URI=""
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE=""
+DEPEND=""
+# Listing default packages for the current release
+RDEPEND="app-admin/eselect-python
+ dev-lang/python:2.7
+ sys-devel/gcc:4.5
+ sys-devel/gcc-config"
+
+SABAYON_VER="${PV}"
+SABAYON_HEADER="Sabayon Linux"
+SABAYON_RELEASE="sabayon-release"
+
+src_unpack () {
+ if use x86; then
+ echo "${SABAYON_HEADER} x86 ${SABAYON_VER}" > "${SABAYON_RELEASE}"
+ else
+ echo "${SABAYON_HEADER} amd64 ${SABAYON_VER}" > "${SABAYON_RELEASE}"
+ fi
+}
+
+src_install () {
+ insinto /etc
+ doins sabayon-release
+ dosym /etc/sabayon-release /etc/system-release
+}
+
+pkg_postinst() {
+ # Setup Python 2.7
+ eselect python update --ignore 3.0 --ignore 3.1 --ignore 3.2 --ignore 3.3 --ignore 3.4
+
+ # Setup GCC 4.5 (it's also in packages.db.post_upgrade.sh
+ c_profile=$(gcc-config -l | grep "\-4.5" | cut -d"[" -f 2 | cut -d"]" -f 1)
+ [[ "${?}" != "0" ]] && ewarn "gcc-config script error" && exit 1
+ if [[ ${c_profile} =~ ^[0-9]+$ ]]; then
+ gcc-config ${c_profile}
+ env-update
+ else
+ ewarn "gcc-config unable to set new profile:" ${c_profile}
+ fi
+}
diff --git a/app-misc/sabayon-version/sabayon-version-6.ebuild b/app-misc/sabayon-version/sabayon-version-6.ebuild
new file mode 100644
index 0000000..3c117e2
--- /dev/null
+++ b/app-misc/sabayon-version/sabayon-version-6.ebuild
@@ -0,0 +1,54 @@
+# Copyright 2004-2011 Sabayon Linux
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=3
+
+DESCRIPTION="Sabayon System Release virtual package"
+HOMEPAGE="http://www.sabayon.org/"
+SRC_URI=""
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE=""
+DEPEND=""
+# Listing default packages for the current release
+RDEPEND="app-admin/eselect-python
+ dev-lang/python:2.7
+ sys-devel/gcc:4.5
+ sys-devel/gcc-config"
+
+SABAYON_VER="${PV}"
+SABAYON_HEADER="Sabayon Linux"
+SABAYON_RELEASE="sabayon-release"
+
+src_unpack () {
+ if use x86; then
+ echo "${SABAYON_HEADER} x86 ${SABAYON_VER}" > "${SABAYON_RELEASE}"
+ else
+ echo "${SABAYON_HEADER} amd64 ${SABAYON_VER}" > "${SABAYON_RELEASE}"
+ fi
+}
+
+src_install () {
+ insinto /etc
+ doins sabayon-release
+ dosym /etc/sabayon-release /etc/system-release
+}
+
+pkg_postinst() {
+ # Setup Python 2.7
+ eselect python update --ignore 3.0 --ignore 3.1 --ignore 3.2 --ignore 3.3 --ignore 3.4
+
+ # Setup GCC 4.5 (it's also in packages.db.post_upgrade.sh
+ c_profile=$(gcc-config -l | grep "\-4.5" | cut -d"[" -f 2 | cut -d"]" -f 1)
+ [[ "${?}" != "0" ]] && ewarn "gcc-config script error" && exit 1
+ if [[ ${c_profile} =~ ^[0-9]+$ ]]; then
+ gcc-config ${c_profile}
+ env-update
+ else
+ ewarn "gcc-config unable to set new profile:" ${c_profile}
+ fi
+}