diff options
author | 2020-04-17 10:29:22 +0300 | |
---|---|---|
committer | 2020-04-17 10:29:22 +0300 | |
commit | 32be9599d88592c6b180bb1e233cd3529bf111e2 (patch) | |
tree | a95c7c03596a027485388f83b8848b2dd1856d0e /Makefile | |
parent | update to cffi/4a4a9e8abe97 (diff) | |
download | pypy-32be9599d88592c6b180bb1e233cd3529bf111e2.tar.gz pypy-32be9599d88592c6b180bb1e233cd3529bf111e2.tar.bz2 pypy-32be9599d88592c6b180bb1e233cd3529bf111e2.zip |
add jobs control, from issue 3187
Diffstat (limited to 'Makefile')
-rw-r--r-- | Makefile | 9 |
1 files changed, 3 insertions, 6 deletions
@@ -11,6 +11,8 @@ endif URAM := $(shell $(RUNINTERP) -c "import sys; print 4.5 if sys.maxint>1<<32 else 2.5") +JOBS=$(subst -j,--make-jobs ,$(filter -j%, $(MAKEFLAGS))) + .PHONY: pypy-c cffi_imports pypy-c: @@ -33,12 +35,7 @@ endif @echo "====================================================================" @echo @sleep 5 - cd pypy/goal && $(RUNINTERP) ../../rpython/bin/rpython -Ojit targetpypystandalone.py - -# Note: the -jN option, or MAKEFLAGS=-jN, are not usable. They are -# replaced with an opaque --jobserver option by the time this Makefile -# runs. We cannot get their original value either: -# http://lists.gnu.org/archive/html/help-make/2010-08/msg00106.html + cd pypy/goal && $(RUNINTERP) ../../rpython/bin/rpython $(JOBS) -Ojit targetpypystandalone.py cffi_imports: pypy-c PYTHONPATH=. pypy/goal/pypy-c pypy/tool/build_cffi_imports.py || /bin/true |