aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArmin Rigo <arigo@tunes.org>2013-05-21 10:00:07 +0200
committerArmin Rigo <arigo@tunes.org>2013-05-21 10:00:07 +0200
commitfcad8a376edb214e63c48bdd0e0d6b81c9cedc6c (patch)
tree15c792a78784066fb045daefd87342d0bde06bb5
parentBump the version number (diff)
downloadpypy-release-2.0.2.tar.gz
pypy-release-2.0.2.tar.bz2
pypy-release-2.0.2.zip
Manual merge of the "doc" directory from trunk.release-2.0.2
-rw-r--r--pypy/doc/coding-guide.rst5
-rw-r--r--pypy/doc/conf.py2
-rw-r--r--pypy/doc/getting-started-python.rst4
-rw-r--r--pypy/doc/getting-started.rst16
-rw-r--r--pypy/doc/how-to-contribute.rst3
-rw-r--r--pypy/doc/how-to-release.rst3
-rw-r--r--pypy/doc/index.rst4
-rw-r--r--pypy/doc/release-2.0.0.rst14
-rw-r--r--pypy/doc/whatsnew-head.rst17
9 files changed, 49 insertions, 19 deletions
diff --git a/pypy/doc/coding-guide.rst b/pypy/doc/coding-guide.rst
index 03f631322e..8792b07d60 100644
--- a/pypy/doc/coding-guide.rst
+++ b/pypy/doc/coding-guide.rst
@@ -339,8 +339,9 @@ We are using
+ methods and other class attributes do not change after startup
+ single inheritance is fully supported
-+ simple mixins work too, but the mixed in class needs a ``_mixin_ = True``
- class attribute
++ simple mixins somewhat work too, but the mixed in class needs a
+ ``_mixin_ = True`` class attribute. isinstance checks against the
+ mixin type will fail when translated.
+ classes are first-class objects too
diff --git a/pypy/doc/conf.py b/pypy/doc/conf.py
index d5121928c2..2971b61a70 100644
--- a/pypy/doc/conf.py
+++ b/pypy/doc/conf.py
@@ -47,7 +47,7 @@ copyright = u'2013, The PyPy Project'
# The short X.Y version.
version = '2.0'
# The full version, including alpha/beta/rc tags.
-release = '2.0-beta1'
+release = '2.0.2'
# The language for content autogenerated by Sphinx. Refer to documentation
# for a list of supported languages.
diff --git a/pypy/doc/getting-started-python.rst b/pypy/doc/getting-started-python.rst
index cdffd709a2..1f31eeb29e 100644
--- a/pypy/doc/getting-started-python.rst
+++ b/pypy/doc/getting-started-python.rst
@@ -105,7 +105,7 @@ executable. The executable behaves mostly like a normal Python interpreter::
$ ./pypy-c
Python 2.7.3 (7e4f0faa3d51, Nov 22 2012, 10:35:18)
- [PyPy 2.0.0-beta1 with GCC 4.7.1] on linux2
+ [PyPy 2.0.0 with GCC 4.7.1] on linux2
Type "help", "copyright", "credits" or "license" for more information.
And now for something completely different: ``RPython magically makes you rich
and famous (says so on the tin)''
@@ -235,7 +235,7 @@ correct hierarchy, so to run PyPy it's enough to unpack the archive, and run
the ``bin/pypy`` executable.
To install PyPy system wide on unix-like systems, it is recommended to put the
-whole hierarchy alone (e.g. in ``/opt/pypy2.0-beta1``) and put a symlink to the
+whole hierarchy alone (e.g. in ``/opt/pypy2.0``) and put a symlink to the
``pypy`` executable into ``/usr/bin`` or ``/usr/local/bin``
If the executable fails to find suitable libraries, it will report
diff --git a/pypy/doc/getting-started.rst b/pypy/doc/getting-started.rst
index 535bc9e15d..8711340fb1 100644
--- a/pypy/doc/getting-started.rst
+++ b/pypy/doc/getting-started.rst
@@ -53,10 +53,10 @@ Installing PyPy
PyPy is ready to be executed as soon as you unpack the tarball or the zip
file, with no need to install it in any specific location::
- $ tar xf pypy-2.0-beta1-linux.tar.bz2
- $ ./pypy-2.0-beta1/bin/pypy
+ $ tar xf pypy-2.0.tar.bz2
+ $ ./pypy-2.0/bin/pypy
Python 2.7.3 (7e4f0faa3d51, Nov 22 2012, 10:35:18)
- [PyPy 2.0.0-beta1 with GCC 4.7.1] on linux2
+ [PyPy 2.0.0 with GCC 4.7.1] on linux2
Type "help", "copyright", "credits" or "license" for more information.
And now for something completely different: ``PyPy is an exciting technology
that lets you to write fast, portable, multi-platform interpreters with less
@@ -75,14 +75,14 @@ install distribute_ and pip_:
$ curl -O https://raw.github.com/pypa/pip/master/contrib/get-pip.py
- $ ./pypy-2.0-beta1/bin/pypy distribute_setup.py
+ $ ./pypy-2.0/bin/pypy distribute_setup.py
- $ ./pypy-2.0-beta1/bin/pypy get-pip.py
+ $ ./pypy-2.0/bin/pypy get-pip.py
- $ ./pypy-2.0-beta1/bin/pip install pygments # for example
+ $ ./pypy-2.0/bin/pip install pygments # for example
-3rd party libraries will be installed in ``pypy-2.0-beta1/site-packages``, and
-the scripts in ``pypy-2.0-beta1/bin``.
+3rd party libraries will be installed in ``pypy-2.0/site-packages``, and
+the scripts in ``pypy-2.0/bin``.
Installing using virtualenv
---------------------------
diff --git a/pypy/doc/how-to-contribute.rst b/pypy/doc/how-to-contribute.rst
index 0b402c3112..9534edba46 100644
--- a/pypy/doc/how-to-contribute.rst
+++ b/pypy/doc/how-to-contribute.rst
@@ -28,7 +28,8 @@ This leads to the next issue:
Layers
------
-PyPy has layers. Those layers help us keep the respective parts separated enough
+PyPy has layers. Just like Ogres or onions.
+Those layers help us keep the respective parts separated enough
to be worked on independently and make the complexity manageable. This is,
again, just a sanity requirement for such a complex project. For example writing
a new optimization for the JIT usually does **not** involve touching a Python
diff --git a/pypy/doc/how-to-release.rst b/pypy/doc/how-to-release.rst
index 59f29473eb..54e045cf1b 100644
--- a/pypy/doc/how-to-release.rst
+++ b/pypy/doc/how-to-release.rst
@@ -22,7 +22,8 @@ Release Steps
will capture the revision number of this change for the release;
some of the next updates may be done before or after branching; make
sure things are ported back to the trunk and to the branch as
- necessary
+ necessary; also update the version number in pypy/doc/conf.py,
+ and in pypy/doc/index.rst
* update pypy/doc/contributor.rst (and possibly LICENSE)
* rename pypy/doc/whatsnew_head.rst to whatsnew_VERSION.rst
and create a fresh whatsnew_head.rst after the release
diff --git a/pypy/doc/index.rst b/pypy/doc/index.rst
index 912e8b58ef..0768e2bc9f 100644
--- a/pypy/doc/index.rst
+++ b/pypy/doc/index.rst
@@ -40,7 +40,7 @@ Index of various topics:
* `FAQ`_: some frequently asked questions.
-* `Release 2.0 beta 2`_: the latest official release
+* `Release 2.0.2`_: the latest official release
* `PyPy Blog`_: news and status info about PyPy
@@ -110,7 +110,7 @@ on the `development mailing list`_.
.. _`Getting Started`: getting-started.html
.. _`Papers`: extradoc.html
.. _`Videos`: video-index.html
-.. _`Release 2.0 beta 2`: http://pypy.org/download.html
+.. _`Release 2.0.2`: http://pypy.org/download.html
.. _`speed.pypy.org`: http://speed.pypy.org
.. _`RPython toolchain`: translation.html
.. _`potential project ideas`: project-ideas.html
diff --git a/pypy/doc/release-2.0.0.rst b/pypy/doc/release-2.0.0.rst
index 91ddd0f7b4..c5bac376a5 100644
--- a/pypy/doc/release-2.0.0.rst
+++ b/pypy/doc/release-2.0.0.rst
@@ -4,6 +4,8 @@ PyPy 2.0 - Einstein Sandwich
We're pleased to announce PyPy 2.0. This is a stable release that brings
a swath of bugfixes, small performance improvements and compatibility fixes.
+PyPy 2.0 is a big step for us and we hope in the future we'll be able to
+provide stable releases more often.
You can download the PyPy 2.0 release here:
@@ -19,6 +21,10 @@ The two biggest changes since PyPy 1.9 are:
.. _`cffi`: http://cffi.readthedocs.org
+If you're using PyPy for anything, it would help us immensely if you fill out
+the following survey: http://bit.ly/pypysurvey This is for the developers
+eyes and we will not make any information public without your agreement.
+
What is PyPy?
=============
@@ -28,8 +34,8 @@ due to its integrated tracing JIT compiler.
This release supports x86 machines running Linux 32/64, Mac OS X 64 or
Windows 32. Windows 64 work is still stalling, we would welcome a volunteer
-to handle that. ARM support is on the way and we're expecting to release
-an alpha ARM version shortly.
+to handle that. ARM support is on the way, as you can see from the recently
+released alpha for ARM.
.. _`pypy 2.0 and cpython 2.7.3`: http://speed.pypy.org
@@ -54,6 +60,10 @@ Highlights
* A lot of stability issues fixed.
+* Refactoring much of the numpypy array classes, which resulted in removal of
+ lazy expression evaluation. On the other hand, we now have more complete
+ dtype support and support more array attributes.
+
.. _`pypycore`: https://github.com/gevent-on-pypy/pypycore/
.. _`pypy-hacks`: https://github.com/schmir/gevent/tree/pypy-hacks
diff --git a/pypy/doc/whatsnew-head.rst b/pypy/doc/whatsnew-head.rst
index 97d2766d77..26e0965836 100644
--- a/pypy/doc/whatsnew-head.rst
+++ b/pypy/doc/whatsnew-head.rst
@@ -5,3 +5,20 @@ What's new in PyPy 2.1
.. this is a revision shortly after release-2.0
.. startrev: a13c07067613
+.. branch: numpy-pickle
+Pickling of numpy arrays and dtypes (including record dtypes)
+
+.. branch: remove-array-smm
+Remove multimethods in the arraymodule
+
+.. branch: callback-stacklet
+Fixed bug when switching stacklets from a C callback
+
+.. branch: remove-set-smm
+Remove multi-methods on sets
+
+.. branch: numpy-subarrays
+Implement subarrays for numpy
+
+.. branch: remove-dict-smm
+Remove multi-methods on dict