aboutsummaryrefslogtreecommitdiff
path: root/htl
diff options
context:
space:
mode:
Diffstat (limited to 'htl')
-rw-r--r--htl/Makefile2
-rw-r--r--htl/pt-internal.h3
2 files changed, 4 insertions, 1 deletions
diff --git a/htl/Makefile b/htl/Makefile
index bb9ef5deba..b2dc797ee4 100644
--- a/htl/Makefile
+++ b/htl/Makefile
@@ -68,7 +68,7 @@ libpthread-routines := pt-attr pt-attr-destroy pt-attr-getdetachstate \
pt-mutexattr-setpshared pt-mutexattr-settype \
pt-mutexattr-getrobust pt-mutexattr-setrobust \
\
- pt-mutex-init pt-mutex-destroy \
+ pt-mutex-init pt-mutex-destroy pt-mutex-checklocked \
pt-mutex-lock pt-mutex-trylock pt-mutex-timedlock \
pt-mutex-unlock \
pt-mutex-transfer-np \
diff --git a/htl/pt-internal.h b/htl/pt-internal.h
index 064e795157..8ffe1bd970 100644
--- a/htl/pt-internal.h
+++ b/htl/pt-internal.h
@@ -301,6 +301,9 @@ extern error_t __pthread_sigstate (struct __pthread *__restrict thread, int how,
const sigset_t *__restrict set,
sigset_t *__restrict oset,
int clear_pending);
+
+/* If supported, check that MUTEX is locked by the caller. */
+extern int __pthread_mutex_checklocked (pthread_mutex_t *mtx);
/* Default thread attributes. */