aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFlorian Weimer <fweimer@redhat.com>2018-10-30 13:11:47 +0100
committerFlorian Weimer <fweimer@redhat.com>2018-10-30 13:17:36 +0100
commitf5e7e95921847bd83186bfe621fc2b48c4de5477 (patch)
treed1750c3c4bff6622fef0599b3f38b1e5efdae558 /support/Makefile
parentRISC-V: properly terminate call chain (bug 23125) (diff)
downloadglibc-f5e7e95921847bd83186bfe621fc2b48c4de5477.tar.gz
glibc-f5e7e95921847bd83186bfe621fc2b48c4de5477.tar.bz2
glibc-f5e7e95921847bd83186bfe621fc2b48c4de5477.zip
stdlib/test-bz22786: Avoid spurious test failures using alias mappings
On systems without enough random-access memory, stdlib/test-bz22786 will go deeply into swap and time out, even with a substantial TIMEOUTFACTOR. This commit adds a facility to construct repeating strings with alias mappings, so that the requirement for physical memory, and uses it in stdlib/test-bz22786.
Diffstat (limited to 'support/Makefile')
-rw-r--r--support/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/support/Makefile b/support/Makefile
index 8b4a7bf8c5..4d307035b3 100644
--- a/support/Makefile
+++ b/support/Makefile
@@ -25,6 +25,7 @@ extra-libs-others = $(extra-libs)
extra-libs-noinstall := $(extra-libs)
libsupport-routines = \
+ blob_repeat \
check \
check_addrinfo \
check_dns_packet \
@@ -190,6 +191,7 @@ $(objpfx)true-container : $(libsupport)
tests = \
README-testing \
tst-support-namespace \
+ tst-support_blob_repeat \
tst-support_capture_subprocess \
tst-support_format_dns_packet \
tst-support_quote_blob \