aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVictor Stinner <vstinner@python.org>2020-11-02 22:03:28 +0100
committerGitHub <noreply@github.com>2020-11-02 22:03:28 +0100
commit5cf4782a2630629d0978bf4cf6b6340365f449b2 (patch)
treee54caf1ea68b6c0ded1d72d72a35db3ab7224138 /Makefile.pre.in
parentbpo-42103: Improve validation of Plist files. (GH-22882) (diff)
downloadcpython-5cf4782a2630629d0978bf4cf6b6340365f449b2.tar.gz
cpython-5cf4782a2630629d0978bf4cf6b6340365f449b2.tar.bz2
cpython-5cf4782a2630629d0978bf4cf6b6340365f449b2.zip
bpo-41796: Make _ast module state per interpreter (GH-23024)
The ast module internal state is now per interpreter. * Rename "astmodulestate" to "struct ast_state" * Add pycore_ast.h internal header: the ast_state structure is now declared in pycore_ast.h. * Add PyInterpreterState.ast (struct ast_state) * Remove get_ast_state() * Rename get_global_ast_state() to get_ast_state() * PyAST_obj2mod() now handles get_ast_state() failures
Diffstat (limited to 'Makefile.pre.in')
-rw-r--r--Makefile.pre.in2
1 files changed, 2 insertions, 0 deletions
diff --git a/Makefile.pre.in b/Makefile.pre.in
index 5b6c0b9b62d..a8912cd4184 100644
--- a/Makefile.pre.in
+++ b/Makefile.pre.in
@@ -840,9 +840,11 @@ regen-ast:
$(PYTHON_FOR_REGEN) $(srcdir)/Parser/asdl_c.py \
$(srcdir)/Parser/Python.asdl \
-H $(srcdir)/Include/Python-ast.h.new \
+ -I $(srcdir)/Include/internal/pycore_ast.h.new \
-C $(srcdir)/Python/Python-ast.c.new
$(UPDATE_FILE) $(srcdir)/Include/Python-ast.h $(srcdir)/Include/Python-ast.h.new
+ $(UPDATE_FILE) $(srcdir)/Include/internal/pycore_ast.h $(srcdir)/Include/internal/pycore_ast.h.new
$(UPDATE_FILE) $(srcdir)/Python/Python-ast.c $(srcdir)/Python/Python-ast.c.new
.PHONY: regen-opcode