aboutsummaryrefslogtreecommitdiff
path: root/Mac
diff options
context:
space:
mode:
authorJack Jansen <jack.jansen@cwi.nl>2004-12-27 16:13:39 +0000
committerJack Jansen <jack.jansen@cwi.nl>2004-12-27 16:13:39 +0000
commit078824e4f67a770d8a92d547e6a52d45843f900c (patch)
treeb4ca561d8f5c5cb9b67d3c39136420b3681741de /Mac
parentUpdated version numbers. (diff)
downloadcpython-078824e4f67a770d8a92d547e6a52d45843f900c.tar.gz
cpython-078824e4f67a770d8a92d547e6a52d45843f900c.tar.bz2
cpython-078824e4f67a770d8a92d547e6a52d45843f900c.zip
Added quotes around the destroot arguments, so empty destroot works.
Diffstat (limited to 'Mac')
-rw-r--r--Mac/OSX/Makefile14
1 files changed, 7 insertions, 7 deletions
diff --git a/Mac/OSX/Makefile b/Mac/OSX/Makefile
index f4bedaee18c..10b0f5d3ccc 100644
--- a/Mac/OSX/Makefile
+++ b/Mac/OSX/Makefile
@@ -120,12 +120,12 @@ install_IDE:
echo See Mac/OSX/README for details; \
else \
echo $(BUILDPYTHON) $(srcdir)/Mac/scripts/BuildApplet.py \
- --destroot $(DESTDIR) \
+ --destroot "$(DESTDIR)" \
--python $(INSTALLED_PYTHONW) \
--output $(DESTDIR)$(PYTHONAPPSDIR)/PythonIDE.app --noargv \
$(srcdir)/Mac/Tools/IDE/PythonIDE.py ; \
$(BUILDPYTHON) $(srcdir)/Mac/scripts/BuildApplet.py \
- --destroot $(DESTDIR) \
+ --destroot "$(DESTDIR)" \
--python $(INSTALLED_PYTHONW) \
--output $(DESTDIR)$(PYTHONAPPSDIR)/PythonIDE.app --noargv \
$(srcdir)/Mac/Tools/IDE/PythonIDE.py; \
@@ -138,7 +138,7 @@ install_PackageManager:
else \
echo $(BUILDPYTHON) $(bundlebuilder) \
--builddir $(DESTDIR)$(PYTHONAPPSDIR)/ \
- --destroot $(DESTDIR) \
+ --destroot "$(DESTDIR)" \
--python $(INSTALLED_PYTHONW) \
--resource $(srcdir)/Mac/Tools/IDE/PythonIDE.rsrc \
--mainprogram $(srcdir)/Mac/Tools/IDE/PackageManager.py \
@@ -146,7 +146,7 @@ install_PackageManager:
--creator Pimp build; \
$(BUILDPYTHON) $(bundlebuilder) \
--builddir $(DESTDIR)$(PYTHONAPPSDIR)/ \
- --destroot $(DESTDIR) \
+ --destroot "$(DESTDIR)" \
--python $(INSTALLED_PYTHONW) \
--resource $(srcdir)/Mac/Tools/IDE/PythonIDE.rsrc \
--mainprogram $(srcdir)/Mac/Tools/IDE/PackageManager.py \
@@ -161,13 +161,13 @@ install_IDLE:
else \
echo $(BUILDPYTHON) $(srcdir)/Mac/scripts/BuildApplet.py \
--python $(INSTALLED_PYTHONW) \
- --destroot $(DESTDIR) \
+ --destroot "$(DESTDIR)" \
--output $(DESTDIR)$(PYTHONAPPSDIR)/IDLE.app \
--extra $(srcdir)/Lib/idlelib \
$(srcdir)/Tools/scripts/idle ; \
$(BUILDPYTHON) $(srcdir)/Mac/scripts/BuildApplet.py \
--python $(INSTALLED_PYTHONW) \
- --destroot $(DESTDIR) \
+ --destroot "$(DESTDIR)" \
--output $(DESTDIR)$(PYTHONAPPSDIR)/IDLE.app \
--extra $(srcdir)/Lib/idlelib:Contents/Resources/idlelib \
$(srcdir)/Tools/scripts/idle ; \
@@ -176,7 +176,7 @@ install_IDLE:
install_BuildApplet:
$(BUILDPYTHON) $(srcdir)/Mac/scripts/BuildApplet.py \
- --destroot $(DESTDIR) \
+ --destroot "$(DESTDIR)" \
--python $(INSTALLED_PYTHONW) \
--output $(DESTDIR)$(PYTHONAPPSDIR)/BuildApplet.app \
$(srcdir)/Mac/scripts/BuildApplet.py