aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNick Coghlan <ncoghlan@gmail.com>2017-06-02 23:30:57 +1000
committerGitHub <noreply@github.com>2017-06-02 23:30:57 +1000
commit7a82f9c2b94d31c8f4cc8bb8e3151765d8b148d7 (patch)
tree1eb705a4f506725c54a2111135a373b81a719fdf /Doc/Makefile
parentbpo-30245: Fix possible overflow when organize struct.pack_into error message... (diff)
downloadcpython-7a82f9c2b94d31c8f4cc8bb8e3151765d8b148d7.tar.gz
cpython-7a82f9c2b94d31c8f4cc8bb8e3151765d8b148d7.tar.bz2
cpython-7a82f9c2b94d31c8f4cc8bb8e3151765d8b148d7.zip
bpo-30052: Always regenerate cross-references (#1339)
* bpo-30052: Always regenerate cross-references The patch for bpo-30052 changed the preferred link target for :func:`bytes` and :func`bytearray` references to be the respective type definitions rather than the corresponding builtin function entries. This patch changes the daily documentation builds to disable the output caching in Sphinx, in order to ensure that cross-reference changes like this one are reliably picked up and applied automatically after merging.
Diffstat (limited to 'Doc/Makefile')
-rw-r--r--Doc/Makefile9
1 files changed, 7 insertions, 2 deletions
diff --git a/Doc/Makefile b/Doc/Makefile
index 94697f95671..ae59f3294f1 100644
--- a/Doc/Makefile
+++ b/Doc/Makefile
@@ -159,15 +159,20 @@ serve:
../Tools/scripts/serve.py build/html
# Targets for daily automated doc build
+# By default, Sphinx only rebuilds pages where the page content has changed.
+# This means it doesn't always pick up changes to preferred link targets, etc
+# To ensure such changes are picked up, we build the published docs with
+# `-E` (to ignore the cached environment) and `-a` (to ignore already existing
+# output files)
# for development releases: always build
autobuild-dev:
- make dist SPHINXOPTS='$(SPHINXOPTS) -A daily=1 -A versionswitcher=1'
+ make dist SPHINXOPTS='$(SPHINXOPTS) -Ea -A daily=1 -A versionswitcher=1'
-make suspicious
# for quick rebuilds (HTML only)
autobuild-dev-html:
- make html SPHINXOPTS='$(SPHINXOPTS) -A daily=1 -A versionswitcher=1'
+ make html SPHINXOPTS='$(SPHINXOPTS) -Ea -A daily=1 -A versionswitcher=1'
# for stable releases: only build if not in pre-release stage (alpha, beta)
# release candidate downloads are okay, since the stable tree can be in that stage