summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/helm/helm-0.4.1.ebuild')
-rw-r--r--media-sound/helm/helm-0.4.1.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/media-sound/helm/helm-0.4.1.ebuild b/media-sound/helm/helm-0.4.1.ebuild
new file mode 100644
index 0000000..ccaf268
--- /dev/null
+++ b/media-sound/helm/helm-0.4.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils
+
+DESCRIPTION="Open source polyphonic software synthesizer with lots of modulation"
+HOMEPAGE="http://tytel.org/helm/"
+SRC_URI="https://github.com/mtytel/helm/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="vst"
+
+RDEPEND="media-libs/alsa-lib
+ media-libs/lv2
+ virtual/opengl
+ x11-libs/libX11
+ x11-libs/libXext"
+DEPEND="${RDEPEND}
+ vst? ( >=media-libs/vst-sdk-2.4 )"
+
+DOCS="README.md"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-vst-location.patch"
+ sed -e 's|/usr/lib/|/usr/'$(get_libdir)'/|' -i Makefile || die
+ epatch_user
+}
+
+src_compile() {
+ emake PREFIX=/usr all $(usex vst vst '')
+}
+
+src_install() {
+ default
+ if use vst; then
+ exeinto /usr/$(get_libdir)/vst
+ doexe builds/linux/VST/build/helm.so
+ fi
+}