summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/chpwdfile/chpwdfile-0.24.ebuild')
-rw-r--r--app-admin/chpwdfile/chpwdfile-0.24.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/app-admin/chpwdfile/chpwdfile-0.24.ebuild b/app-admin/chpwdfile/chpwdfile-0.24.ebuild
new file mode 100644
index 0000000..17399ef
--- /dev/null
+++ b/app-admin/chpwdfile/chpwdfile-0.24.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header$
+
+DESCRIPTION="console based password management application"
+HOMEPAGE="http://cpbotha.net/pam_pwdfile"
+SRC_URI="http://cpbotha.net/files/mirror/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+DEPEND="virtual/libc"
+
+src_compile() {
+ emake || die "emake failed"
+}
+
+src_install() {
+ dobin chpwdfile
+ doman chpwdfile.1
+ for i in pw{add,mod,del}; do
+ dosym chpwdfile /usr/bin/${i}
+ echo '.so chpwdfile.1' > ${i}.1
+ doman ${i}.1
+ done
+ dodoc README
+}