summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Proschofsky <suka@gentoo.org>2008-02-19 08:20:16 +0000
committerAndreas Proschofsky <suka@gentoo.org>2008-02-19 08:20:16 +0000
commitd1c6e44391a3184d55e5e0d211771534c8c80f5a (patch)
tree843461fb02478b49783567b3122b8ec072d1e59d /gnome-extra
parentVersion bump for Conduit (diff)
downloadsuka-d1c6e44391a3184d55e5e0d211771534c8c80f5a.tar.gz
suka-d1c6e44391a3184d55e5e0d211771534c8c80f5a.tar.bz2
suka-d1c6e44391a3184d55e5e0d211771534c8c80f5a.zip
Add ebuilds for the shiny new application launcher gnome-do and the corresponding gnome-do-plugins
svn path=/; revision=54
Diffstat (limited to 'gnome-extra')
-rw-r--r--gnome-extra/gnome-do-plugins/Manifest2
-rw-r--r--gnome-extra/gnome-do-plugins/gnome-do-plugins-0.3.0.ebuild30
-rw-r--r--gnome-extra/gnome-do/Manifest2
-rw-r--r--gnome-extra/gnome-do/gnome-do-0.3.2.1.ebuild30
4 files changed, 64 insertions, 0 deletions
diff --git a/gnome-extra/gnome-do-plugins/Manifest b/gnome-extra/gnome-do-plugins/Manifest
new file mode 100644
index 0000000..789a466
--- /dev/null
+++ b/gnome-extra/gnome-do-plugins/Manifest
@@ -0,0 +1,2 @@
+DIST do-plugins-0.3.0.tar.gz 130888 RMD160 377dc757d3801faf685b24f84e6e774a6a7f0af2 SHA1 66fa25504bb3d8a197c953e8c09bdaad344b50cb SHA256 5697ffa2af2c8f1e893e9c015fae8c4d4195ed80dfc536c4e9f088a3bafd6333
+EBUILD gnome-do-plugins-0.3.0.ebuild 773 RMD160 a91be5841d5fc7bd8f49ceab81d0bb367ceda371 SHA1 6721688eec133d80a2a3cf8b1f0b16f18e68ce64 SHA256 a6cbcacabaa1e86a18b431dddce0405783251d41a842f381f190be9d9569d9f5
diff --git a/gnome-extra/gnome-do-plugins/gnome-do-plugins-0.3.0.ebuild b/gnome-extra/gnome-do-plugins/gnome-do-plugins-0.3.0.ebuild
new file mode 100644
index 0000000..086e5bc
--- /dev/null
+++ b/gnome-extra/gnome-do-plugins/gnome-do-plugins-0.3.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+inherit gnome2 mono eutils
+
+DESCRIPTION="Set of extra plugins for gnome-do"
+HOMEPAGE="http://do.davebsd.com/"
+MY_P="do-plugins-${PV}"
+SRC_URI="https://launchpad.net/gc/trunk/0.3.2.1/+download/${MY_P}.tar.gz"
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+S="${WORKDIR}/${MY_P}"
+
+RDEPEND=">=dev-lang/mono-1.2
+ >=dev-dotnet/gtk-sharp-2
+ >=dev-dotnet/gconf-sharp-2
+ >=dev-dotnet/evolution-sharp-0.14
+ >=sys-apps/dbus-0.90
+ >=x11-libs/gtk+-2.6.0
+ >=dev-libs/atk-1.2.4
+ >=gnome-base/gconf-2
+ >=gnome-extra/gnome-do-0.3.2.1"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ dev-util/pkgconfig
+ >=dev-util/intltool-0.35"
+
+DOCS="AUTHORS COPYRIGHT"
diff --git a/gnome-extra/gnome-do/Manifest b/gnome-extra/gnome-do/Manifest
new file mode 100644
index 0000000..d8bb54d
--- /dev/null
+++ b/gnome-extra/gnome-do/Manifest
@@ -0,0 +1,2 @@
+DIST gnome-do-0.3.2.1.tar.gz 182804 RMD160 a77dd48b6d0695d503f264322a3017c53519ab1d SHA1 d7fbdd55bf52ac7d7d0f59f839a8c71e26cad883 SHA256 eb22e2c4d6373278c3d015c98d77e64fdea70c68a39833a8f928af8a5fd1eec0
+EBUILD gnome-do-0.3.2.1.ebuild 819 RMD160 0d1116260ab43fbb403f8fac0891a975b54482ae SHA1 d9ac55d027da6213128dc7446587f58aca9fc88b SHA256 2f3989e78dd259cb3f690f1c7f9f5f39658fb7b8119060f3ff98f4f3984cd348
diff --git a/gnome-extra/gnome-do/gnome-do-0.3.2.1.ebuild b/gnome-extra/gnome-do/gnome-do-0.3.2.1.ebuild
new file mode 100644
index 0000000..b44ab73
--- /dev/null
+++ b/gnome-extra/gnome-do/gnome-do-0.3.2.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+inherit gnome2 mono eutils
+
+DESCRIPTION="A powerful, speedy, and sexy remote control for your GNOME Desktop."
+HOMEPAGE="http://do.davebsd.com/"
+SRC_URI="https://launchpad.net/gc/trunk/0.3.2.1/+download/${P}.tar.gz"
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+RDEPEND=">=dev-lang/mono-1.2
+ >=dev-dotnet/gtk-sharp-2
+ >=dev-dotnet/gconf-sharp-2
+ >=dev-dotnet/gnome-sharp-2
+ >=dev-dotnet/dbus-sharp-0.6
+ >=dev-dotnet/dbus-glib-sharp-0.4
+ >=dev-dotnet/glade-sharp-2
+ >=sys-apps/dbus-0.90
+ >=x11-libs/gtk+-2.6.0
+ >=dev-libs/atk-1.2.4
+ >=gnome-base/gconf-2"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ dev-util/pkgconfig
+ >=dev-util/intltool-0.35"
+
+DOCS="AUTHORS COPYING HACKING"