summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Proschofsky <suka@gentoo.org>2009-08-11 21:57:17 +0000
committerAndreas Proschofsky <suka@gentoo.org>2009-08-11 21:57:17 +0000
commit2248780c9e3c803a7d4b2da30283b32765498098 (patch)
treee67092e3d1b6429e49eed194c290a5d73fcddd51
parentAdd ebuilds for GNOME Shell alpha (diff)
downloadsuka-2248780c9e3c803a7d4b2da30283b32765498098.tar.gz
suka-2248780c9e3c803a7d4b2da30283b32765498098.tar.bz2
suka-2248780c9e3c803a7d4b2da30283b32765498098.zip
quick fixes
svn path=/; revision=138
-rw-r--r--eclass/clutter.eclass42
-rw-r--r--gnome-base/gnome-shell/Manifest2
2 files changed, 43 insertions, 1 deletions
diff --git a/eclass/clutter.eclass b/eclass/clutter.eclass
new file mode 100644
index 0000000..79de44e
--- /dev/null
+++ b/eclass/clutter.eclass
@@ -0,0 +1,42 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+#
+# clutter.eclass
+#
+# Sets SRC_URI, SLOT, and a few deps
+#
+# Authors:
+# Nirbheek Chauhan <nirbheek@gentoo.org>
+#
+
+inherit versionator
+
+HOMEPAGE="http://www.clutter-project.org/"
+
+RV=($(get_version_components))
+SRC_URI="http://www.clutter-project.org/sources/${PN}/${RV[0]}.${RV[1]}/${P}.tar.bz2"
+LICENSE="LGPL-2"
+
+DEPEND="dev-util/pkgconfig"
+
+DOCS="AUTHORS ChangeLog NEWS README TODO"
+
+clutter_src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ # examples
+ if hasq examples ${IUSE} && use examples; then
+ insinto /usr/share/doc/${PF}/examples
+
+ for example in ${EXAMPLES}; do
+ # If directory
+ if [[ ${example: -1} = "/" ]]; then
+ doins -r ${example}
+ else
+ doins ${example}
+ fi
+ done
+ fi
+}
diff --git a/gnome-base/gnome-shell/Manifest b/gnome-base/gnome-shell/Manifest
index f04eb4d..1bafe90 100644
--- a/gnome-base/gnome-shell/Manifest
+++ b/gnome-base/gnome-shell/Manifest
@@ -1,2 +1,2 @@
DIST gnome-shell-2.27.0.tar.bz2 437202 RMD160 9d13cb841472b0cdc9a6bbfc7da48be95429ca09 SHA1 9bf1f96e4d70505101730579d396cd32e2488bce SHA256 df59d50e7653abfcf05d7d94f0aaefe8f05329e47d5c43510418622a40e84fb0
-EBUILD gnome-shell-2.27.0.ebuild 1153 RMD160 507b43bf7312a7956ad14c1dd8a5ef3a36021ca2 SHA1 7ce73a3aac53dc7283793dafde64f6213656a31f SHA256 14d8cd37e999663fbe452465e252c468faf5c45ddec4a6da69aa1871a1a630aa
+EBUILD gnome-shell-2.27.0.ebuild 1281 RMD160 ca90b8ffeeacb4d5efccea9926034b7d8ab73715 SHA1 2cba05e09c64143e61554608acb6eb39fd0c63fd SHA256 93bf2a1f99693a52f5d531cb64d9fd61a58c5752f9de4031ed54b43dba0ce8d9