summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-kernel/gentoo-sources/gentoo-sources-2.6.27-r12.ebuild')
-rw-r--r--sys-kernel/gentoo-sources/gentoo-sources-2.6.27-r12.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/sys-kernel/gentoo-sources/gentoo-sources-2.6.27-r12.ebuild b/sys-kernel/gentoo-sources/gentoo-sources-2.6.27-r12.ebuild
new file mode 100644
index 0000000..17710bb
--- /dev/null
+++ b/sys-kernel/gentoo-sources/gentoo-sources-2.6.27-r12.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/gentoo-sources/gentoo-sources-2.6.27-r10.ebuild,v 1.3 2009/10/21 18:21:24 armin76 Exp $
+
+ETYPE="sources"
+K_WANT_GENPATCHES="base extras"
+K_GENPATCHES_VER="14"
+inherit kernel-2
+detect_version
+detect_arch
+
+KEYWORDS="~alpha ~amd64 ~arm -hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+HOMEPAGE="http://dev.gentoo.org/~dsd/genpatches"
+
+GENPATCHES_URI=""
+for i in ${K_WANT_GENPATCHES} ; do
+ tarball="genpatches-${OKV}-${K_GENPATCHES_VER}.${i}.tar.bz2"
+ GENPATCHES_URI="http://dev.gentoo.org/~pva/${tarball} ${GENPATCHES_URI}"
+done
+DESCRIPTION="Full sources including the Gentoo patchset for the ${KV_MAJOR}.${KV_MINOR} kernel tree"
+SRC_URI="${KERNEL_URI} ${GENPATCHES_URI} ${ARCH_URI}"
+
+pkg_postinst() {
+ kernel-2_pkg_postinst
+ einfo "For more info on this patchset, and how to report problems, see:"
+ einfo "${HOMEPAGE}"
+}