summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWulf Krueger <philantrop@gentoo.org>2007-07-22 13:44:52 +0000
committerWulf Krueger <philantrop@gentoo.org>2007-07-22 13:44:52 +0000
commitdd35ab2a07b65de5bee50811c5cddfda3671e421 (patch)
treee8fb3ff4572ee2d3d634161c92a3880df0ad1b6f
parentLauncher application for qemu. (diff)
downloadphilantrop-dd35ab2a07b65de5bee50811c5cddfda3671e421.tar.gz
philantrop-dd35ab2a07b65de5bee50811c5cddfda3671e421.tar.bz2
philantrop-dd35ab2a07b65de5bee50811c5cddfda3671e421.zip
Yet another launcher application for qemu.
svn path=/trunk/; revision=13
-rw-r--r--app-emulation/qtemu/Manifest8
-rw-r--r--app-emulation/qtemu/files/digest-qtemu-1.0.23
-rw-r--r--app-emulation/qtemu/qtemu-1.0.2.ebuild55
3 files changed, 66 insertions, 0 deletions
diff --git a/app-emulation/qtemu/Manifest b/app-emulation/qtemu/Manifest
new file mode 100644
index 0000000..2819176
--- /dev/null
+++ b/app-emulation/qtemu/Manifest
@@ -0,0 +1,8 @@
+DIST qtemu-1.0.2.tar.bz2 487947 RMD160 52e0df223e7f0eeca81894d46ff1e70cb23e04ce SHA1 3fdf3285ef51a9060f51a794f6a62fc982a217ee SHA256 5b5de0a09684f3cdb6a7088d9ccaf5db01f4cec40df241cd5ced5e95dcbaef2e
+EBUILD qtemu-1.0.2.ebuild 1514 RMD160 658a77b1231fe72c769a10b1be8b7e96f688045a SHA1 465a14c121d7bae78ff4cc41a1dc91ce7588a342 SHA256 708a19ae5ddb8bf3dca878aa5d961667adf70748622ddccfcd3ffa0d21fba538
+MD5 5a29d1c9c1b1ea8231b05b945c12568c qtemu-1.0.2.ebuild 1514
+RMD160 658a77b1231fe72c769a10b1be8b7e96f688045a qtemu-1.0.2.ebuild 1514
+SHA256 708a19ae5ddb8bf3dca878aa5d961667adf70748622ddccfcd3ffa0d21fba538 qtemu-1.0.2.ebuild 1514
+MD5 0e1ef2df261c7b4d9ad1a46b0ba542c2 files/digest-qtemu-1.0.2 238
+RMD160 24010ca3f2ec3e51971b802a17a604f8ed47f402 files/digest-qtemu-1.0.2 238
+SHA256 1c6896d1b82a64052993bcddd6802b7486d97a69676a8a45aa63d8dc17ddabf0 files/digest-qtemu-1.0.2 238
diff --git a/app-emulation/qtemu/files/digest-qtemu-1.0.2 b/app-emulation/qtemu/files/digest-qtemu-1.0.2
new file mode 100644
index 0000000..0172e51
--- /dev/null
+++ b/app-emulation/qtemu/files/digest-qtemu-1.0.2
@@ -0,0 +1,3 @@
+MD5 e1a36688177b8160d0b06b9ee3d7b338 qtemu-1.0.2.tar.bz2 487947
+RMD160 52e0df223e7f0eeca81894d46ff1e70cb23e04ce qtemu-1.0.2.tar.bz2 487947
+SHA256 5b5de0a09684f3cdb6a7088d9ccaf5db01f4cec40df241cd5ced5e95dcbaef2e qtemu-1.0.2.tar.bz2 487947
diff --git a/app-emulation/qtemu/qtemu-1.0.2.ebuild b/app-emulation/qtemu/qtemu-1.0.2.ebuild
new file mode 100644
index 0000000..ab362a2
--- /dev/null
+++ b/app-emulation/qtemu/qtemu-1.0.2.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit cmake-utils
+# A well-used example of an eclass function that needs eutils is epatch. If
+# your source needs patches applied, it's suggested to put your patch in the
+# 'files' directory and use:
+#
+# epatch ${FILESDIR}/patch-name-here
+#
+
+DESCRIPTION="QtEmu is a graphical user interface for QEMU written in Qt4."
+HOMEPAGE="http://qtemu.org/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+LICENSE="GPL-2 LGPL-2"
+
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+
+# use any USE flags, set to "".
+IUSE=""
+
+RESTRICT="nomirrors"
+
+# Build-time dependencies, such as
+# ssl? ( >=dev-libs/openssl-0.9.6b )
+# >=dev-lang/perl-5.6.1-r1
+# It is advisable to use the >= syntax show above, to reflect what you
+# had installed on your system when you tested the package. Then
+# other users hopefully won't be caught without the right version of
+# a dependency.
+DEPEND=">=dev-util/cmake-2.4.3
+ >=x11-libs/qt-4.2.2"
+RDEPEND="${DEPEND}"
+
+# Source directory; the dir where the sources can be found (automatically
+# unpacked) inside ${WORKDIR}. The default value for S is ${WORKDIR}/${P}
+# If you don't need to change it, leave the S= line out of the ebuild
+# to keep it tidy.
+S="${WORKDIR}/${PN}"
+
+src_compile() {
+
+ mycmakeargs="-DCMAKE_INSTALL_PREFIX=/opt/qtemu"
+
+ cmake_utils_src_configureout
+ cmake_utils_src_make
+
+}
+
+src_install() {
+ cmake-utils_src_install
+ dosym /opt/qtemu/bin/qtemu /usr/bin/qtemu
+}