summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-gfx/shotwell')
-rw-r--r--media-gfx/shotwell/Manifest3
-rw-r--r--media-gfx/shotwell/files/shotwell-0.6.1-vala-0.9-fixes.patch59
-rw-r--r--media-gfx/shotwell/shotwell-0.6.1.ebuild52
3 files changed, 114 insertions, 0 deletions
diff --git a/media-gfx/shotwell/Manifest b/media-gfx/shotwell/Manifest
new file mode 100644
index 0000000..27f5d5b
--- /dev/null
+++ b/media-gfx/shotwell/Manifest
@@ -0,0 +1,3 @@
+AUX shotwell-0.6.1-vala-0.9-fixes.patch 2261 RMD160 271aab83c391f7a14d94a33ef88744bbb086048f SHA1 272a4ed1cf61ec56b987028534ead9594dbffbbd SHA256 62f82c128f4a532a4a59b6e0b5e2bc9c0113ccc862bd57e0849aaa118d455202
+DIST shotwell-0.6.1.tar.bz2 681013 RMD160 45ef932fcc46b12713cf334c31a57cd18fdc2915 SHA1 824c119ddbc853b07fcce373f92a16ff384f64b1 SHA256 01314373d35f05bcdc223eb06a0f21e76ae3e3e1d6628822816a147db1d534dc
+EBUILD shotwell-0.6.1.ebuild 1397 RMD160 25e59f8bd95f4a94cef2745fd835db90bd32a139 SHA1 4e5035e1271a236decd4ecc526b668ddc86926fb SHA256 1584efb48aaef0eba7136ca57077eddce2152466d96e853c9f9971e220d82ac3
diff --git a/media-gfx/shotwell/files/shotwell-0.6.1-vala-0.9-fixes.patch b/media-gfx/shotwell/files/shotwell-0.6.1-vala-0.9-fixes.patch
new file mode 100644
index 0000000..10d608a
--- /dev/null
+++ b/media-gfx/shotwell/files/shotwell-0.6.1-vala-0.9-fixes.patch
@@ -0,0 +1,59 @@
+Index: src/ImportPage.vala
+===================================================================
+--- src/ImportPage.vala (revision 1951)
++++ src/ImportPage.vala (revision 1952)
+@@ -620,8 +620,8 @@
+ mount.unmounted.connect(on_unmounted);
+
+ debug("Unmounting camera ...");
+- mount.unmount_with_operation(MountUnmountFlags.NONE, new Gtk.MountOperation(AppWindow.get_instance()),
+- null, on_unmount_finished);
++ mount.unmount_with_operation.begin(MountUnmountFlags.NONE,
++ new Gtk.MountOperation(AppWindow.get_instance()), null, on_unmount_finished);
+
+ return true;
+ }
+@@ -631,7 +631,7 @@
+
+ Mount mount = (Mount) source;
+ try {
+- mount.unmount_with_operation_finish(aresult);
++ mount.unmount_with_operation.end(aresult);
+ } catch (Error err) {
+ AppWindow.error_message(UNMOUNT_FAILED_MSG);
+
+Index: src/util.vala
+===================================================================
+--- src/util.vala (revision 1951)
++++ src/util.vala (revision 1952)
+@@ -635,7 +635,7 @@
+ return ((AppInfo) a).get_name().down().collate(((AppInfo) b).get_name().down());
+ }
+
+-public SortedList<AppInfo> get_apps_for_mime_types(string[] mime_types) {
++public SortedList<AppInfo> get_apps_for_mime_types(string[] mime_types) {
+ SortedList<AppInfo> external_apps = new SortedList<AppInfo>(app_info_comparator);
+
+ if (mime_types.length == 0)
+@@ -644,10 +644,10 @@
+ // 3 loops because SortedList.contains() wasn't paying nicely with AppInfo,
+ // probably because it has a special equality function
+ foreach (string mime_type in mime_types) {
+- unowned string content_type = g_content_type_from_mime_type(mime_type);
+- if (content_type == null)
+- break;
+-
++ string content_type = g_content_type_from_mime_type(mime_type);
++ if (content_type == null)
++ break;
++
+ foreach (AppInfo external_app in
+ AppInfo.get_all_for_type(content_type)) {
+ bool already_contains = false;
+@@ -709,4 +709,4 @@
+ #else
+ return "/";
+ #endif
+-}
+\ No newline at end of file
++}
diff --git a/media-gfx/shotwell/shotwell-0.6.1.ebuild b/media-gfx/shotwell/shotwell-0.6.1.ebuild
new file mode 100644
index 0000000..9e59732
--- /dev/null
+++ b/media-gfx/shotwell/shotwell-0.6.1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/shotwell/shotwell-0.5.2.ebuild,v 1.1 2010/05/30 06:20:04 hollow Exp $
+
+EAPI="2"
+GCONF_DEBUG="no"
+
+inherit eutils gnome2 versionator
+
+MY_PV=$(get_version_component_range 1-2)
+DESCRIPTION="Open source photo manager for GNOME"
+HOMEPAGE="http://www.yorba.org/shotwell/"
+SRC_URI="http://www.yorba.org/download/${PN}/${MY_PV}/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-db/sqlite-3.5.9:3
+ >=dev-libs/dbus-glib-0.80
+ >=dev-libs/libgee-0.5.0
+ >=dev-libs/libunique-1.0.0
+ >=dev-libs/libxml2-2.6.32
+ >=gnome-base/gconf-2.22.0
+ >=media-libs/libexif-0.6.16
+ >=media-libs/libgexiv2-0.1.0
+ >=media-libs/libgphoto2-2.4.2
+ >=media-libs/libraw-0.9.0
+ >=net-libs/libsoup-2.26.0
+ >=net-libs/webkit-gtk-1.1.5
+ >=sys-fs/udev-145[extras]
+ >=x11-libs/gtk+-2.18.0:2"
+DEPEND="${RDEPEND}
+ >=dev-lang/vala-0.8"
+
+DOCS="AUTHORS MAINTAINERS NEWS README THANKS"
+
+src_prepare() {
+ G2CONF="--disable-schemas-install
+ --disable-desktop-update
+ --disable-icon-update"
+
+ epatch "${FILESDIR}/${P}-vala-0.9-fixes.patch"
+}
+
+src_install() {
+ # This is needed so that gnome2_gconf_savelist() works correctly.
+ insinto "${EPREFIX}"/etc/gconf/schemas
+ doins misc/shotwell.schemas || die "install gconf schema failed"
+ gnome2_src_install
+}