summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'gnome-extra')
-rw-r--r--gnome-extra/xchat-indicator/Manifest2
-rw-r--r--gnome-extra/xchat-indicator/xchat-indicator-0.3.2.ebuild35
2 files changed, 37 insertions, 0 deletions
diff --git a/gnome-extra/xchat-indicator/Manifest b/gnome-extra/xchat-indicator/Manifest
new file mode 100644
index 0000000..2670f0a
--- /dev/null
+++ b/gnome-extra/xchat-indicator/Manifest
@@ -0,0 +1,2 @@
+DIST xchat-indicator-0.3.2.tar.gz 287084 RMD160 c5861a86f856c2947ac86f0072d239a39dbc2945 SHA1 5da1f32a179cf0f41081149b6555b9c20056d6c1 SHA256 3ae672df9e9d3f67eae3bde2d344927a926d89e427f6e92829809bf5e201521a
+EBUILD xchat-indicator-0.3.2.ebuild 869 RMD160 ce83a65839bd0acd9fcdc6ad6b8c5682517673e9 SHA1 bb557dc9edcbd7df8b38dccab4774c780642376e SHA256 c64f3ba517f34e89040f94dab214f2f989052827526deba0c871085a7effe6df
diff --git a/gnome-extra/xchat-indicator/xchat-indicator-0.3.2.ebuild b/gnome-extra/xchat-indicator/xchat-indicator-0.3.2.ebuild
new file mode 100644
index 0000000..7fc31f9
--- /dev/null
+++ b/gnome-extra/xchat-indicator/xchat-indicator-0.3.2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="2"
+
+inherit gnome2
+
+DESCRIPTION="Plugin to make XChat use the messaging indicator"
+HOMEPAGE="https://launchpad.net/xchat-indicator"
+SRC_URI="http://launchpad.net/${PN}/trunk/${PV}/+download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND=">=x11-libs/gtk+-2.14.0
+ >=dev-libs/libindicate-0.3.0
+ net-irc/xchat-gnome"
+DEPEND="${COMMON_DEPEND}
+ dev-util/pkgconfig"
+
+pkg_setup() {
+ G2CONF="--disable-dependency-tracking --disable-static"
+ DOCS="AUTHORS NEWS"
+}
+
+src_prepare() {
+ gnome2_src_prepare
+
+ # Don't use embedded header, use system header instead.
+ # xchat-gnome installs its own xchat-gnome/xchat-plugin.h so we've to use it
+ sed "s:\"\(xchat-plugin.h\)\":<xchat-gnome/\1>:g" -i indicator.c || die "sed failed"
+}