summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/bufferpool-git/bufferpool-git-0.1.ebuild')
-rw-r--r--dev-libs/bufferpool-git/bufferpool-git-0.1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-libs/bufferpool-git/bufferpool-git-0.1.ebuild b/dev-libs/bufferpool-git/bufferpool-git-0.1.ebuild
new file mode 100644
index 0000000..75e3b21
--- /dev/null
+++ b/dev-libs/bufferpool-git/bufferpool-git-0.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit git autotools
+
+EGIT_REPO_URI="git://live.polito.it/var/git/bufferpool.git"
+EGIT_BOOTSTRAP="eautoreconf"
+
+DESCRIPTION="Simple memory management library"
+HOMEPAGE="http://live.polito.it/documentation/bufferpool"
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~ppc64"
+IUSE=""
+
+RDEPEND=""
+DEPEND=""
+
+AT_M4DIR="m4"
+
+src_compile() {
+ econf || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR=${D} install || die "make install failed"
+ dodoc README ChangeLog
+}