summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <hans@degraaff.org>2024-11-10 08:27:19 +0100
committerHans de Graaff <hans@degraaff.org>2024-11-10 08:27:19 +0100
commit550ddd148f72d1b7774239756278b176bedce8e9 (patch)
treef1e60666121e24b50bd9cb9b96594809ddb95f22
parentdev-ruby/roda: drop 3.70.0 (diff)
downloadgraaff-550ddd148f72d1b7774239756278b176bedce8e9.tar.gz
graaff-550ddd148f72d1b7774239756278b176bedce8e9.tar.bz2
graaff-550ddd148f72d1b7774239756278b176bedce8e9.zip
dev-ruby/rubocop: add 1.68.0
Signed-off-by: Hans de Graaff <hans@degraaff.org>
-rw-r--r--dev-ruby/rubocop/Manifest1
-rw-r--r--dev-ruby/rubocop/rubocop-1.68.0.ebuild76
2 files changed, 77 insertions, 0 deletions
diff --git a/dev-ruby/rubocop/Manifest b/dev-ruby/rubocop/Manifest
index 17a1cc40..1b59702e 100644
--- a/dev-ruby/rubocop/Manifest
+++ b/dev-ruby/rubocop/Manifest
@@ -1,3 +1,4 @@
DIST rubocop-1.64.1.tar.gz 2506128 BLAKE2B 27d98933f631d5a8f17fe6fe2fe14817122a5867b15fc39e0cfe51a802c978c40cd0e70d53a6e2cb2ae70dddae0f39139eb00f5e28c2ebaa55993ee00fa65ed2 SHA512 5298065d6f1052210f84d4e8ab5c2afd9042da7620f49afcdaae0ebb6831b1436861975238012185c9c639f4ab1bcc736e45cacfcc94ab2b1303b086581f8028
DIST rubocop-1.65.0.tar.gz 2510192 BLAKE2B c3f2919a97649dde552bc0867caac5698c0151943731ef54c9f62f557aa1412fc37d0ab017bff5509ab05048a5a21bdf73c910027ce282f54d2ed3af6d2450d6 SHA512 ccdf5a7081a9275f325c1d71716ce67d775b83b6fe1ad95d806121de4a6fd1fc9d66fd8d54c408eac74037bc3a980ebdc583539120ecdf39f3c9f895454e557a
DIST rubocop-1.66.0.tar.gz 2519753 BLAKE2B e3bd3bc7b90f8acd2c4d5a6078c2eace450879de4fded32870b9aa7f9724d85295f115dea29a25bf16f58d810189856d336ed31b155f923c8c634804d509983f SHA512 0e84fe207066458f0e515844ceeb656517344e3e5874589161a3a35cbd3624c357e7d69ec85f59f65cdacb7aa1e2617f84a293257798fbc3d6e217560c3709fa
+DIST rubocop-1.68.0.tar.gz 2565900 BLAKE2B 60ff21f7c079622fcc80c2c365c6a94900cbbf67167277fc477899936d561bab889d9acffffbfaec4aa4234c5b47fcc2a4adf1ef0e25b6ee0b257aef7f796734 SHA512 224c97942498e022f736e2f50f6b9a6c202985ee4beeb1615e3e59d16f83a1ea19b0b3731a33de9ccd000124864091167bed9a61691027830a0955c627bcddf5
diff --git a/dev-ruby/rubocop/rubocop-1.68.0.ebuild b/dev-ruby/rubocop/rubocop-1.68.0.ebuild
new file mode 100644
index 00000000..9d9cfb44
--- /dev/null
+++ b/dev-ruby/rubocop/rubocop-1.68.0.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby31 ruby32 ruby33"
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_EXTRAINSTALL="assets config"
+RUBY_FAKEGEM_BINDIR="exe"
+
+RUBY_FAKEGEM_GEMSPEC="rubocop.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A Ruby static code analyzer"
+HOMEPAGE="https://github.com/rubocop/rubocop"
+SRC_URI="https://github.com/rubocop/rubocop/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+ruby_add_rdepend "
+ >=dev-ruby/json-2.3:2
+ >=dev-ruby/language_server-protocol-3.17.0
+ >=dev-ruby/parallel-1.10:1
+ >=dev-ruby/parser-3.3.0.2
+ dev-ruby/rainbow:3
+ dev-ruby/regexp_parser:2
+ >=dev-ruby/rubocop-ast-1.32.2:1
+ >=dev-ruby/ruby-progressbar-1.7:0
+ >=dev-ruby/unicode-display_width-2.4.0:2"
+
+ruby_add_bdepend "test? ( dev-ruby/bundler dev-ruby/rubocop-performance dev-ruby/webmock )"
+
+all_ruby_prepare() {
+ sed -e '/pry/ s:^:#:' \
+ -i spec/spec_helper.rb || die
+ sed -i -e "s:_relative ': './:" ${RUBY_FAKEGEM_GEMSPEC} || die
+
+ # Avoid bundler spec
+ sed -e '/and the gem is bundled/,/^ end/ s:^:#:' \
+ -e '/when a file inherits from \(a url inheriting from a gem\|an unknown gem\)/ s/context/xcontext/' \
+ -e '/returns values from the gem config with local overrides/ s/it/xit/' \
+ -i spec/rubocop/config_loader_spec.rb || die
+ sed -i -e '/gem_versions_in_target/ s/describe/xdescribe/' spec/rubocop/config_spec.rb || die
+ sed -e '/when the extensions are loaded via inherit_gem/ s/context/xcontext/' \
+ -i spec/rubocop/config_obsoletion_spec.rb || die
+ sed -i -e '/bundler integration/,/^ end/ s:^:#:' spec/rubocop/cli_spec.rb || die
+ rm -f spec/rubocop/cli_spec.rb spec/rubocop/cli/suggest_extensions_spec.rb spec/rubocop/lockfile_spec.rb || die
+
+ # Avoid specs requiring rubocop-rake
+ sed -i -e '/compliance with rubocop/,/^ end/ s:^:#:' spec/rubocop/cop/generator_spec.rb || die
+
+ # Avoid specs requiring many rubocop extensions
+ rm -f spec/rubocop/version_spec.rb || die
+
+ # Avoid specs that are not functional and break too often in releases
+ sed -i -e '/has a unique contributor name/askip "too fragile"' spec/project_spec.rb || die
+
+ # Avoid spec that breaks when YJIT is enabled
+ sed -i -e '/logs the RuboCop version/ s/it/xit/' spec/rubocop/lsp/server_spec.rb || die
+
+ sed -e 's:/tmp/example:'"${TMPDIR}"'/example:' \
+ -e 's:/tmp/Gemfile:'"${TMPDIR}"'/Gemfile:' \
+ -i spec/rubocop/cop/team_spec.rb || die
+ sed -e 's:/tmp:'"${TMPDIR}"':' -i spec/rubocop/server/cli_spec.rb || die
+
+ # Disable the strict warnings check since we will have additional dependencies with warnings.
+ sed -e '/StrictWarnings.enable/ s:^:#:' \
+ -i spec/spec_helper.rb || die
+}