summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <hans@degraaff.org>2024-11-15 07:56:20 +0100
committerHans de Graaff <hans@degraaff.org>2024-11-15 07:56:20 +0100
commit51bd5d9c0c623c2743f6e50f14b93f614f902d62 (patch)
treec682caa52d0f619747bd761c8b85a577e35789b8
parentdev-ruby/kicks: new package, add 3.1.1 (diff)
downloadgraaff-51bd5d9c0c623c2743f6e50f14b93f614f902d62.tar.gz
graaff-51bd5d9c0c623c2743f6e50f14b93f614f902d62.tar.bz2
graaff-51bd5d9c0c623c2743f6e50f14b93f614f902d62.zip
dev-ruby/rubocop-performance: add 1.23.0
Signed-off-by: Hans de Graaff <hans@degraaff.org>
-rw-r--r--dev-ruby/rubocop-performance/Manifest1
-rw-r--r--dev-ruby/rubocop-performance/rubocop-performance-1.23.0.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-ruby/rubocop-performance/Manifest b/dev-ruby/rubocop-performance/Manifest
index fc9abda5..5129aa2a 100644
--- a/dev-ruby/rubocop-performance/Manifest
+++ b/dev-ruby/rubocop-performance/Manifest
@@ -3,3 +3,4 @@ DIST rubocop-performance-1.21.0.tar.gz 107352 BLAKE2B 978ec215a7d7d63e7e4c30d6a5
DIST rubocop-performance-1.21.1.tar.gz 107216 BLAKE2B 8801df04e9e1c6f3d221f857887d2067785bdecf2846286e8c007c1acdf984d4c8009a8b093e0d1ba553e2bdac64569ad0f258b3c15eaa3924eaf8eafd05180a SHA512 9171267e45205e4a870e3b5d6212cf8b1aaf9146c353b222b109276aff1d4894006b46965d93b43ddc03438804b224e4eebf3e55c826057a74e1abcdda6c049e
DIST rubocop-performance-1.22.0.tar.gz 107476 BLAKE2B 990eb27d70842c836a0374fdaa5ecd09d2ae053ff6962cf6217885b778a59c1433aa9cf6cc0f5fc4452602ed06f03096c64e3b4087b324dad0b12740e1434026 SHA512 cfeea8e20f539b65da3c08f335cd19f5789ac6bed6808728f87a108366608bfafb2aac1199afc9bd2226a59d94531735144e32df1fd32a8d91f4a4900c0079a9
DIST rubocop-performance-1.22.1.tar.gz 107864 BLAKE2B fb0215a5dc7990ab12aeb8a43fa94cb2936bdc201ee72602673f34a49821d7e800adfa366a0172c312213632aa2a76b54336f3740397c89dbcaf150443fdda3d SHA512 2d18bcdf28eeec2a0f2af8a284d6973058cc96524c0f811e892992ca9de483a5f867ea117f0080eee8bb290f0c73313f0d79146dcc5aa56b2d5a72b956718287
+DIST rubocop-performance-1.23.0.tar.gz 109975 BLAKE2B 8fe412caa3a8bfe6ca64036ffe3c2dbc48740a2d4d263805ab51167c31b90e713360bf9d75dd7542312484c7b900442daeac1fce90b4b58f625649677dc5383d SHA512 c1c7900f26cbf1a620cc9842fbd29ec9dbc52adb02f86fd9acfec609f2e1d2ea4246efd3ebc8524e4f621cfdebf5fb4f23548ea1b5da31bb20f2852d4ffd975f
diff --git a/dev-ruby/rubocop-performance/rubocop-performance-1.23.0.ebuild b/dev-ruby/rubocop-performance/rubocop-performance-1.23.0.ebuild
new file mode 100644
index 00000000..ec2a15b7
--- /dev/null
+++ b/dev-ruby/rubocop-performance/rubocop-performance-1.23.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby31 ruby32 ruby33"
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_EXTRAINSTALL="config"
+
+RUBY_FAKEGEM_GEMSPEC="rubocop-performance.gemspec"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="A collection of RuboCop cops to check for performance optimizations in Ruby code"
+HOMEPAGE="https://github.com/rubocop/rubocop-performance/"
+SRC_URI="https://github.com/rubocop/rubocop-performance/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+ruby_add_rdepend "
+ >=dev-ruby/rubocop-1.48.1:0
+ >=dev-ruby/rubocop-ast-1.31.1
+"