summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Olexa <darkside@gentoo.org>2011-06-23 20:17:22 +0000
committerJeremy Olexa <darkside@gentoo.org>2011-06-23 20:17:22 +0000
commiteb62ad11701387ab7775103cabbc12696b703f43 (patch)
tree307272ed2f014b857d484992f70fe238034cb219
parent[dev-util/catalyst] Cleanup ebuild by migrating to EAPI4 and other improvements (diff)
downloaddarkside-eb62ad11701387ab7775103cabbc12696b703f43.tar.gz
darkside-eb62ad11701387ab7775103cabbc12696b703f43.tar.bz2
darkside-eb62ad11701387ab7775103cabbc12696b703f43.zip
[dev-util/catalyst] Re-align with gx86 with a few custom mods
-rw-r--r--dev-util/catalyst/Manifest2
-rw-r--r--dev-util/catalyst/catalyst-2.0.6.916.ebuild40
2 files changed, 23 insertions, 19 deletions
diff --git a/dev-util/catalyst/Manifest b/dev-util/catalyst/Manifest
index 0d85cf9..f9e70bc 100644
--- a/dev-util/catalyst/Manifest
+++ b/dev-util/catalyst/Manifest
@@ -1,3 +1,3 @@
AUX 0001-generic_stage_target.py-stupify-the-LockDir-call.patch 1512 RMD160 219572f242e29eeae6f5a5d115ca80680453141b SHA1 41bd132d4c62b6a31fb4114c901dac8a00b2a9e2 SHA256 9de2cc4861feb0526e5c20633c901a2d376169b50fb8a422c17a599494d39800
DIST catalyst-2.0.6.916.tar.bz2 807678 RMD160 2603b46b38258a2812888416da71c99cd0d7d3a4 SHA1 49ce32a3fcbd5c171a29d0f921b54479c691c18d SHA256 434e59d1233d9215a6deda5f12a64af1241ba3fcaae4ee63145cd9b488b5a968
-EBUILD catalyst-2.0.6.916.ebuild 1953 RMD160 0407fec5a85bdd77dbb2dc44a7d6abb2b50ca8a9 SHA1 a2e2c4c9a54356458b683ddbef33c813e04e84c5 SHA256 eebaf6fd03ce809765ab974a120273e0e65cedc415742c5b5e65a6f7c5cf5081
+EBUILD catalyst-2.0.6.916.ebuild 1882 RMD160 9a6a03b2832d7e5a3e9e78bb9515fa6c144bd547 SHA1 ddb7a08d3bbe7fe88da76c2b2e1999ba8d0494f9 SHA256 4be0e35ba6729a22ccb1c4473f4859c6a38b93784e215bcd5d8883c75d39d387
diff --git a/dev-util/catalyst/catalyst-2.0.6.916.ebuild b/dev-util/catalyst/catalyst-2.0.6.916.ebuild
index e3f5bb4..72e134a 100644
--- a/dev-util/catalyst/catalyst-2.0.6.916.ebuild
+++ b/dev-util/catalyst/catalyst-2.0.6.916.ebuild
@@ -1,17 +1,30 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/catalyst/catalyst-2.0.6.914.ebuild,v 1.1 2011/02/09 20:28:25 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/catalyst/catalyst-2.0.6.916.ebuild,v 1.2 2011/06/22 19:36:33 sping Exp $
+
+# catalyst-9999 -> latest Git
+# catalyst-VER -> normal catalyst release
EAPI=4
inherit eutils multilib
+if [[ ${PV} == 9999* ]]; then
+ EGIT_REPO_URI="git://git.overlays.gentoo.org/proj/catalyst.git"
+ inherit git
+ SRC_URI=""
+ S="${WORKDIR}/${PN}"
+ KEYWORDS=""
+else
+ SRC_URI="mirror://gentoo/${P}.tar.bz2
+ http://wolf31o2.org/sources/${PN}/${P}.tar.bz2"
+ KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~x86-fbsd"
+fi
+
DESCRIPTION="release metatool used for creating releases based on Gentoo Linux"
-HOMEPAGE="http://www.gentoo.org/proj/en/releng/catalyst/index.xml"
-SRC_URI="mirror://gentoo/${P}.tar.bz2"
+HOMEPAGE="http://www.gentoo.org/proj/en/releng/catalyst/"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~x86-fbsd"
IUSE="ccache"
DEPEND=""
@@ -22,7 +35,6 @@ RDEPEND="dev-lang/python
ia64? ( sys-fs/dosfstools )
kernel_linux? ( app-misc/zisofs-tools >=sys-fs/squashfs-tools-2.1 )"
-
src_prepare() {
epatch "${FILESDIR}"/0001*.patch
}
@@ -31,7 +43,11 @@ src_install() {
insinto /usr/$(get_libdir)/${PN}
exeinto /usr/$(get_libdir)/${PN}
doexe catalyst
- doins -r arch modules livecd
+ if [[ ${PV} == 9999* ]]; then
+ doins -r modules files
+ else
+ doins -r arch modules livecd
+ fi
for x in targets/*; do
exeinto /usr/$(get_libdir)/${PN}/$x
doexe $x/*
@@ -50,15 +66,3 @@ src_install() {
dosed "s:/usr/lib/catalyst:/usr/$(get_libdir)/catalyst:" \
/etc/catalyst/catalyst.conf
}
-
-pkg_postinst() {
- if ! use ccache ; then
- ewarn "By default, ccache support for catalyst is disabled."
- ewarn "If this is not what you intended,"
- ewarn "then you should add ccache to your USE."
- fi
- einfo "The template spec files are now installed by default. You can find"
- einfo "them under /usr/share/doc/${PF}/examples"
- einfo "and they are considered to be the authorative source of information"
- einfo "on catalyst."
-}