summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Olexa <darkside@gentoo.org>2008-08-19 11:36:50 -0500
committerJeremy Olexa <darkside@gentoo.org>2008-08-19 11:36:50 -0500
commit9be3ed1cc58bc5fc54655313f01da5afb5b01c0e (patch)
treeeea58d62c379c1478218416cd916837934287683
parentinitial commit to include patch for T61 from bug 221955 (diff)
downloaddarkside-9be3ed1cc58bc5fc54655313f01da5afb5b01c0e.tar.gz
darkside-9be3ed1cc58bc5fc54655313f01da5afb5b01c0e.tar.bz2
darkside-9be3ed1cc58bc5fc54655313f01da5afb5b01c0e.zip
tpb: add tpb-9999 ebuild because the svn trunk has T61 specific changes according to the author
-rw-r--r--app-laptop/tpb/tpb-9999.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/app-laptop/tpb/tpb-9999.ebuild b/app-laptop/tpb/tpb-9999.ebuild
new file mode 100644
index 0000000..3d04ce6
--- /dev/null
+++ b/app-laptop/tpb/tpb-9999.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-laptop/tpb/tpb-0.6.4.ebuild,v 1.5 2007/07/22 09:43:31 omp Exp $
+
+inherit linux-info eutils subversion
+
+DESCRIPTION="IBM ThinkPad buttons utility"
+HOMEPAGE="http://savannah.nongnu.org/projects/tpb/"
+SRC_URI=""
+ESVN_REPO_URI="svn://svn.savannah.nongnu.org/tpb/trunk"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="" # I do not support this for anyone.
+
+IUSE="nls xosd"
+
+DEPEND="x11-libs/libXt
+ x11-libs/libXext
+ xosd? ( >=x11-libs/xosd-2.2.0 )"
+
+CONFIG_CHECK="~NVRAM"
+ERROR_NVRAM="${P} requires /dev/nvram support (CONFIG_NVRAM)"
+
+src_compile() {
+ econf \
+ $(use_enable nls) \
+ $(use_enable xosd) \
+ || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+
+ dodoc README ChangeLog CREDITS TODO
+ dodoc doc/{callback_example.sh,nvram.txt,tpbrc}
+}