summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAgostino Sarubbo <ago@gentoo.org>2012-10-20 23:23:11 +0200
committerAgostino Sarubbo <ago@gentoo.org>2012-10-20 23:23:11 +0200
commit8610fae4ea0b5e6f5da913e7bd56580a7b3cc118 (patch)
treeb394383c41355b714815666063729ead34cdc216 /media-video/uvcdynctrl/uvcdynctrl-0.2.2.ebuild
parentsync with changes I did in the main tree (diff)
downloadago-8610fae4ea0b5e6f5da913e7bd56580a7b3cc118.tar.gz
ago-8610fae4ea0b5e6f5da913e7bd56580a7b3cc118.tar.bz2
ago-8610fae4ea0b5e6f5da913e7bd56580a7b3cc118.zip
Initial import for uvcdynctrl
Diffstat (limited to 'media-video/uvcdynctrl/uvcdynctrl-0.2.2.ebuild')
-rw-r--r--media-video/uvcdynctrl/uvcdynctrl-0.2.2.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/media-video/uvcdynctrl/uvcdynctrl-0.2.2.ebuild b/media-video/uvcdynctrl/uvcdynctrl-0.2.2.ebuild
new file mode 100644
index 0000000..4f638a7
--- /dev/null
+++ b/media-video/uvcdynctrl/uvcdynctrl-0.2.2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+
+inherit cmake-utils
+MY_PN="libwebcam"
+MY_P="${MY_PN}-src-${PV}"
+
+HOMEPAGE="foo"
+DESCRIPTION="bar"
+SRC_URI="mirror://sourceforge/${MY_PN}/${MY_P}.tar.gz"
+
+KEYWORDS="amd64"
+SLOT="0"
+LICENSE="GPL-3"
+IUSE="static-libs"
+
+DEPEND="dev-libs/libxml2"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+src_install() {
+ cmake-utils_src_install
+ use static-libs || rm -fr "${D}"usr/lib64/${MY_PN}.a
+}