aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2008-08-20 08:52:30 +0000
committerAlexis Ballier <aballier@gentoo.org>2008-08-20 08:52:30 +0000
commitf0beb4cb27fd942e043a1a28d2d0310d6506c4cf (patch)
treef86900dc5fdae31b63f44a1e5ec25e4ce01f7261
parentgenerate licenselists files from the catalogue (diff)
downloadaballier-f0beb4cb27fd942e043a1a28d2d0310d6506c4cf.tar.gz
aballier-f0beb4cb27fd942e043a1a28d2d0310d6506c4cf.tar.bz2
aballier-f0beb4cb27fd942e043a1a28d2d0310d6506c4cf.zip
map catalogue licenses to ours
svn path=/; revision=298
-rw-r--r--scripts/texlive/tlpsrc/Makefile7
-rwxr-xr-xscripts/texlive/tlpsrc/cataloguelicense2gentoolicense.sh51
-rw-r--r--scripts/texlive/tlpsrc/texlive-basicbin.extraexec2
3 files changed, 59 insertions, 1 deletions
diff --git a/scripts/texlive/tlpsrc/Makefile b/scripts/texlive/tlpsrc/Makefile
index 9acdac2..7b2d2ee 100644
--- a/scripts/texlive/tlpsrc/Makefile
+++ b/scripts/texlive/tlpsrc/Makefile
@@ -29,6 +29,9 @@ lists : $(FULLDESC:%=%.list) $(FULLDESC:%=%.base)
%.licenselist: %.tlpobj
./getlicense.sh $(shell cat $(<:%.tlpobj=%.list)) | sort | uniq | tr '\n' ' ' > $@
+%.gentoolicense: %.licenselist
+ ./cataloguelicense2gentoolicense.sh $(shell cat $<) | sort | uniq | tr '\n' ' ' > $@
+
%.desc: %.base
grep "shortdesc " $< | sed -e "s/shortdesc //" | sed -e "s/.*/DESCRIPTION=\"TeXLive \0\"/" > $@
@@ -120,7 +123,9 @@ ebuilds: dist $(DESC:%=%.desc) $(DESC:%=%.ebuild) $(DESC:%=%.deps)
tlpobj: $(DESC:%=%.tlpobj)
-licenselist: $(DESC:%=%.licenselist)
+licenselist: $(DESC:%=%.licenselist) $(EXTRA_DIST:%=%.licenselist)
+
+gentoolicenses: $(DESC:%=%.gentoolicense) $(EXTRA_DIST:%=%.gentoolicense)
%.installed: %.ebuild %.metadata
$(MKDIRP) $(TEXLIVE_OVERLAY_LOCATION)/dev-texlive/$(@:%.installed=%)
diff --git a/scripts/texlive/tlpsrc/cataloguelicense2gentoolicense.sh b/scripts/texlive/tlpsrc/cataloguelicense2gentoolicense.sh
new file mode 100755
index 0000000..66ff574
--- /dev/null
+++ b/scripts/texlive/tlpsrc/cataloguelicense2gentoolicense.sh
@@ -0,0 +1,51 @@
+#!/bin/bash
+while [ $# -gt 0 ] ; do
+ case "$1" in
+ gpl)
+ echo "GPL-1";;
+ gpl2)
+ echo "GPL-2";;
+ lppl)
+ echo "LPPL-1.2";;
+ lppl1.2)
+ echo "LPPL-1.2";;
+ lppl1.3)
+ echo "LPPL-1.3";;
+ gfl)
+ echo "LPPL-1.3";;
+ gfsl)
+ echo "LPPL-1.3";;
+ unknown)
+ echo "freedist";;
+ other-free)
+ echo "as-is";;
+ other)
+ echo "as-is";;
+ lgpl)
+ echo "LGPL-2";;
+ lgpl2.1)
+ echo "LGPL-2.1";;
+ pd)
+ echo "public-domain";;
+ apache2)
+ echo "Apache-2.0";;
+ artistic2)
+ echo "Artistic-2";;
+ artistic)
+ echo "Artistic";;
+ bsd)
+ echo "BSD";;
+ knuth)
+ echo "TeX";;
+ fdl)
+ echo "FDL-1.1";;
+ ofl)
+ echo "OFL";;
+ nosell)
+ echo "freedist";;
+ *)
+ echo "The $1 license is not mapped yet!"
+ exit 1;;
+ esac
+ shift
+done
diff --git a/scripts/texlive/tlpsrc/texlive-basicbin.extraexec b/scripts/texlive/tlpsrc/texlive-basicbin.extraexec
index ad37b18..8705066 100644
--- a/scripts/texlive/tlpsrc/texlive-basicbin.extraexec
+++ b/scripts/texlive/tlpsrc/texlive-basicbin.extraexec
@@ -1,4 +1,6 @@
sed -i -e "s/bin-xdvi //" $@
sed -i -e "s/bin-dvipdfm //" $@
sed -i -e "s/bin-dvipdfmx //" $@
+sed -i -e "s/dvipdfmx-def //" $@
+sed -i -e "s/luatex //" $@
sed -i -e "s/texlive-infra/texlive.infra/" $@