summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-plugins/wmsystray/wmsystray-0.1.1.ebuild')
-rw-r--r--x11-plugins/wmsystray/wmsystray-0.1.1.ebuild10
1 files changed, 8 insertions, 2 deletions
diff --git a/x11-plugins/wmsystray/wmsystray-0.1.1.ebuild b/x11-plugins/wmsystray/wmsystray-0.1.1.ebuild
index 633cadcf8795..8ee0afe6af4f 100644
--- a/x11-plugins/wmsystray/wmsystray-0.1.1.ebuild
+++ b/x11-plugins/wmsystray/wmsystray-0.1.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmsystray/wmsystray-0.1.1.ebuild,v 1.2 2004/07/18 00:43:27 dholm Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmsystray/wmsystray-0.1.1.ebuild,v 1.3 2004/08/26 20:33:11 s4t4n Exp $
inherit eutils
@@ -15,14 +15,20 @@ RDEPEND=""
SLOT="0"
LICENSE="GPL-2"
-KEYWORDS="~x86 ~ppc"
+KEYWORDS="x86 ~ppc"
src_unpack() {
unpack ${A}
cd ${S}
+
+ # Let's honour Gentoo CFLAGS
epatch ${FILESDIR}/${PN}-cflags.patch
+ # Fix for #61704, cannot compile with gcc 3.4.1:
+ # it's a trivial change and does not affect other compilers...
+ epatch ${FILESDIR}/${PN}-gcc-3.4.patch
+
}
src_compile() {