summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-plugins/wmmon/wmmon-1.0_beta2-r3.ebuild')
-rw-r--r--x11-plugins/wmmon/wmmon-1.0_beta2-r3.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/x11-plugins/wmmon/wmmon-1.0_beta2-r3.ebuild b/x11-plugins/wmmon/wmmon-1.0_beta2-r3.ebuild
new file mode 100644
index 000000000000..d57ded844d7c
--- /dev/null
+++ b/x11-plugins/wmmon/wmmon-1.0_beta2-r3.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmmon/wmmon-1.0_beta2-r3.ebuild,v 1.1 2005/05/11 07:45:03 s4t4n Exp $
+
+inherit eutils
+
+S="${WORKDIR}/${PN}.app"
+IUSE=""
+DESCRIPTION="Dockable system resources monitor applet for WindowMaker"
+WMMON_VERSION=1_0b2
+SRC_URI="http://rpig.dyndns.org/~anstinus/Linux/${PN}-${WMMON_VERSION}.tar.gz"
+HOMEPAGE="http://www.bensinclair.com/dockapp/"
+
+DEPEND="virtual/x11
+ >=sys-apps/sed-4"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~sparc ~amd64 ~ppc"
+
+src_unpack() {
+ unpack ${A} ; cd ${S}/${PN}
+ epatch ${FILESDIR}/${P}-kernel26-v2.patch
+ sed -i -e "s|-O2|${CFLAGS}|" Makefile
+}
+
+src_compile() {
+ emake -C ${PN} || die
+}
+
+src_install () {
+ dobin wmmon/wmmon
+ dodoc BUGS CHANGES COPYING HINTS INSTALL README TODO
+}