summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/dnd/ChangeLog5
-rw-r--r--x11-libs/dnd/dnd-1.1.ebuild3
-rw-r--r--x11-libs/dnd/files/Makefile-fix.patch34
3 files changed, 40 insertions, 2 deletions
diff --git a/x11-libs/dnd/ChangeLog b/x11-libs/dnd/ChangeLog
index c8ed481000c6..936f94a86c90 100644
--- a/x11-libs/dnd/ChangeLog
+++ b/x11-libs/dnd/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for x11-libs/dnd
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/dnd/ChangeLog,v 1.9 2004/06/24 21:59:22 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/dnd/ChangeLog,v 1.10 2004/07/03 14:00:17 pyrania Exp $
+
+ 03 Jul 2004; <pyrania@gentoo.org> +files/Makefile-fix.patch, dnd-1.1.ebuild:
+ Fixing parallel compilation. See bug #44047.
17 Apr 2004; Daniel Ahlberg <aliz@gentoo.org> dnd-1.1.ebuild:
Inherit eutils, added IUSE=
diff --git a/x11-libs/dnd/dnd-1.1.ebuild b/x11-libs/dnd/dnd-1.1.ebuild
index c1b77201bd11..8835fea71d20 100644
--- a/x11-libs/dnd/dnd-1.1.ebuild
+++ b/x11-libs/dnd/dnd-1.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/dnd/dnd-1.1.ebuild,v 1.17 2004/06/24 21:59:22 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/dnd/dnd-1.1.ebuild,v 1.18 2004/07/03 14:00:17 pyrania Exp $
inherit eutils
@@ -19,6 +19,7 @@ src_unpack() {
unpack dnd.1.1.tgz
cd ${S}
epatch ${FILESDIR}/${PF}-gentoo.diff || die
+ epatch ${FILESDIR}/Makefile-fix.patch || die
}
src_compile() {
diff --git a/x11-libs/dnd/files/Makefile-fix.patch b/x11-libs/dnd/files/Makefile-fix.patch
new file mode 100644
index 000000000000..ca129175b25f
--- /dev/null
+++ b/x11-libs/dnd/files/Makefile-fix.patch
@@ -0,0 +1,34 @@
+--- Makefile.in.orig 1997-05-22 22:18:22.000000000 -0400
++++ Makefile.in 2004-06-16 14:41:19.673035936 -0400
+@@ -42,19 +42,22 @@
+ $(COMPILE) dndtest.c
+ $(LINK) dndtest.o -L. -lDnd $(LIBS)
+
+-libDnd.a: DragAndDrop.c
+- rm -f DragAndDrop.o
+- $(COMPILE) DragAndDrop.c
++libDnd.a: DragAndDropC.o
+ rm -f libDnd.a
+- $(AR) cru libDnd.a DragAndDrop.o
++ $(AR) cru libDnd.a DragAndDropC.o
+ $(RANLIB) libDnd.a
+
+-libDnd++.a: DragAndDrop.c
+- rm -f DragAndDrop.o DragAndDrop.cxx
+- ln -s DragAndDrop.c DragAndDrop.cxx
+- $(CXXCOMPILE) DragAndDrop.cxx
++DragAndDropC.o: DragAndDrop.c
++ rm -f DragAndDropC.o
++ $(COMPILE) DragAndDrop.c -o DragAndDropC.o
++
++DragAndDropCpp.o: DragAndDrop.c
++ rm -f DragAndDropCpp.o
++ $(CXXCOMPILE) DragAndDrop.c -o DragAndDropCpp.o
++
++libDnd++.a: DragAndDropCpp.o
+ rm -f libDnd++.a
+- $(AR) cru libDnd++.a DragAndDrop.o
++ $(AR) cru libDnd++.a DragAndDropCpp.o
+ $(RANLIB) libDnd++.a
+
+ clean: