summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-power/pm-utils/pm-utils-1.3.0-r2.ebuild')
-rw-r--r--sys-power/pm-utils/pm-utils-1.3.0-r2.ebuild35
1 files changed, 13 insertions, 22 deletions
diff --git a/sys-power/pm-utils/pm-utils-1.3.0-r2.ebuild b/sys-power/pm-utils/pm-utils-1.3.0-r2.ebuild
index f6cda725fa02..cefba347b0c4 100644
--- a/sys-power/pm-utils/pm-utils-1.3.0-r2.ebuild
+++ b/sys-power/pm-utils/pm-utils-1.3.0-r2.ebuild
@@ -1,10 +1,9 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-power/pm-utils/pm-utils-1.3.0-r2.ebuild,v 1.2 2010/04/20 20:20:48 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-power/pm-utils/pm-utils-1.3.0-r2.ebuild,v 1.3 2010/05/03 19:31:50 ssuominen Exp $
-EAPI="2"
-
-inherit autotools base
+EAPI=2
+inherit autotools eutils
DESCRIPTION="Suspend and hibernation utilities"
HOMEPAGE="http://pm-utils.freedesktop.org/"
@@ -13,7 +12,7 @@ SRC_URI="http://pm-utils.freedesktop.org/releases/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
-IUSE="alsa debug doc networkmanager ntp video_cards_intel video_cards_radeon"
+IUSE="alsa debug networkmanager ntp video_cards_intel video_cards_radeon"
vbetool="!video_cards_intel? ( sys-apps/vbetool )"
RDEPEND="
@@ -26,14 +25,8 @@ RDEPEND="
ntp? ( net-misc/ntp )
amd64? ( ${vbetool} )
x86? ( ${vbetool} )
- video_cards_radeon? ( app-laptop/radeontool )
-"
-DEPEND="doc? ( app-text/xmlto )"
-
-PATCHES=(
- "${FILESDIR}/${PV}-fix_autotools.patch"
- "${FILESDIR}/${PV}-on_ac_power-upower.patch"
-)
+ video_cards_radeon? ( app-laptop/radeontool )"
+DEPEND="app-text/xmlto"
src_prepare() {
local ignore="01grub"
@@ -43,23 +36,21 @@ src_prepare() {
use debug && echo 'PM_DEBUG="true"' > "${S}/gentoo"
echo "HOOK_BLACKLIST=\"${ignore}\"" >> "${S}/gentoo"
- # write makefile patch
- base_src_prepare
+ epatch "${FILESDIR}"/${PV}-fix_autotools.patch \
+ "${FILESDIR}"/${PV}-on_ac_power-upower.patch
eautoreconf
}
src_configure() {
econf \
- --docdir=/usr/share/doc/${PF} \
- $(use_enable doc)
+ --docdir=/usr/share/doc/${PF}
}
src_install() {
- base_src_install
-
- dodoc AUTHORS ChangeLog NEWS pm/HOWTO* README* TODO || die "dodoc failed"
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS ChangeLog NEWS pm/HOWTO* README* TODO || die
- insinto /etc/pm/config.d/
- doins "${S}/gentoo" || die "doins failed"
+ insinto /etc/pm/config.d
+ doins gentoo || die
}