summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-kernel/win4lin-sources/win4lin-sources-2.4.26.ebuild')
-rw-r--r--sys-kernel/win4lin-sources/win4lin-sources-2.4.26.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/sys-kernel/win4lin-sources/win4lin-sources-2.4.26.ebuild b/sys-kernel/win4lin-sources/win4lin-sources-2.4.26.ebuild
new file mode 100644
index 000000000000..0b6e80eea5b8
--- /dev/null
+++ b/sys-kernel/win4lin-sources/win4lin-sources-2.4.26.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/win4lin-sources/win4lin-sources-2.4.26.ebuild,v 1.1 2004/06/01 17:47:24 plasmaroo Exp $
+
+# OKV=original kernel version, KV=patched kernel version. They can be the same.
+
+IUSE=""
+ETYPE="sources"
+inherit kernel eutils
+OKV="2.4.26"
+KV="2.4.26-win4lin"
+EXTRAVERSION="-win4lin"
+
+S=${WORKDIR}/linux-${KV}
+
+DESCRIPTION="Full sources for the Linux kernel, with Win4Lin support."
+SRC_URI="mirror://kernel/linux/kernel/v2.4/linux-${OKV}.tar.bz2
+ http://www.netraverse.com/member/downloads/files/mki-adapter.patch
+ http://www.netraverse.com/member/downloads/files/Kernel-Win4Lin3-${OKV}.patch"
+HOMEPAGE="http://www.kernel.org/ http://www.netraverse.com/"
+KEYWORDS="~x86"
+SLOT="${KV}"
+
+src_unpack() {
+ unpack linux-${OKV}.tar.bz2
+ mv linux-${OKV} linux-${KV} || die
+
+ cd linux-${KV}
+ epatch ${DISTDIR}/Kernel-Win4Lin3-${OKV}.patch || die "Error: Win4Lin3 patch failed."
+ ebegin 'Applying mki-adapter.patch'
+ patch -Np1 -i ${DISTDIR}/mki-adapter.patch >/dev/null 2>&1 || die "Error: mki-adapter patch failed."
+ eend $?
+ epatch ${FILESDIR}/${P}.CAN-2004-0394.patch || die "Failed to add the CAN-2004-0394 patch!"
+
+ kernel_universal_unpack
+}