summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-kernel/gentoo-dev-sources/gentoo-dev-sources-2.6.4.ebuild')
-rw-r--r--sys-kernel/gentoo-dev-sources/gentoo-dev-sources-2.6.4.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/sys-kernel/gentoo-dev-sources/gentoo-dev-sources-2.6.4.ebuild b/sys-kernel/gentoo-dev-sources/gentoo-dev-sources-2.6.4.ebuild
new file mode 100644
index 000000000000..4d564823f36f
--- /dev/null
+++ b/sys-kernel/gentoo-dev-sources/gentoo-dev-sources-2.6.4.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/gentoo-dev-sources/gentoo-dev-sources-2.6.4.ebuild,v 1.1 2004/03/14 01:02:23 johnm Exp $
+
+ETYPE="sources"
+inherit kernel-2
+detect_version
+
+#version of gentoo patchset
+GPV=4.26
+GPV_SRC="mirror://gentoo/genpatches-${KV_MAJOR}.${KV_MINOR}-${GPV}.tar.bz2"
+
+KEYWORDS="~x86 ~amd64"
+
+UNIPATCH_LIST="${DISTDIR}/genpatches-${KV_MAJOR}.${KV_MINOR}-${GPV}.tar.bz2"
+UNIPATCH_DOCS="${WORKDIR}/patches/genpatches-${KV_MAJOR}.${KV_MINOR}-${GPV}/README"
+
+DESCRIPTION="Full sources including the gentoo patchset for the ${KV_MAJOR}.${KV_MINOR} kernel tree"
+SRC_URI="${KERNEL_URI} ${GPV_SRC}"
+
+DEPEND="${DEPEND} >=dev-libs/ucl-1"
+
+pkg_postinst() {
+ postinst_sources
+
+ ewarn "IMPORTANT:"
+ ewarn "ptyfs support has now been dropped from devfs and as a"
+ ewarn "result you are now required to compile this support into"
+ ewarn "the kernel. You can do so by enabling the following options"
+ ewarn " Device Drivers -> Character devices -> Unix98 PTY Support"
+ ewarn " File systems -> Pseudo filesystems -> /dev/pts filesystem."
+ echo
+ ewarn "If you choose to use UCL/gcloop please ensure you compile gcloop"
+ ewarn "without -fstack-protector."
+ echo
+}