summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-devel/pmake')
-rw-r--r--sys-devel/pmake/ChangeLog9
-rw-r--r--sys-devel/pmake/Manifest4
-rw-r--r--sys-devel/pmake/files/digest-pmake-1.45-r31
-rw-r--r--sys-devel/pmake/pmake-1.45-r3.ebuild58
4 files changed, 69 insertions, 3 deletions
diff --git a/sys-devel/pmake/ChangeLog b/sys-devel/pmake/ChangeLog
index 8f7692913155..f8013e13e411 100644
--- a/sys-devel/pmake/ChangeLog
+++ b/sys-devel/pmake/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-devel/pmake
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/pmake/ChangeLog,v 1.7 2004/01/15 05:20:23 avenj Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/pmake/ChangeLog,v 1.8 2004/02/07 15:04:07 agriffis Exp $
+
+*pmake-1.45-r3 (07 Feb 2004)
+
+ 07 Feb 2004; <agriffis@gentoo.org> pmake-1.45-r3.ebuild:
+ Clean up this ebuild. Fix the arch support, which was messy and (I think)
+ wrong because CFLAGS was being overridden without including the defines. This
+ fixes bug 39159
15 Jan 2004; Jon Portnoy <avenj@gentoo.org> pmake-1.45-r2.ebuild :
Stable on AMD64.
diff --git a/sys-devel/pmake/Manifest b/sys-devel/pmake/Manifest
index d64bcc25847f..67b531b73aea 100644
--- a/sys-devel/pmake/Manifest
+++ b/sys-devel/pmake/Manifest
@@ -1,6 +1,6 @@
-MD5 4b57bbca577e83366ac9559101eda733 ChangeLog 1048
+MD5 fe3aff122289ba7c2ede049ed5726304 ChangeLog 1315
MD5 9a09f8d531c582e78977dbfd96edc1f2 metadata.xml 164
-MD5 1ef9787141052c385c46d37d42a4c632 pmake-1.45-r3.ebuild 1532
+MD5 5095ef814a21698c2018b234cca91da2 pmake-1.45-r3.ebuild 1534
MD5 619d0976672df7e89310bd147ea2a106 pmake-1.45-r2.ebuild 1669
MD5 56b250e5c99455640556fcb776b9bd7e files/01_all_groffpatch.patch 485
MD5 1095ca9c07bda375bf9674fe20d79ba6 files/02_all_mktemp.patch 406
diff --git a/sys-devel/pmake/files/digest-pmake-1.45-r3 b/sys-devel/pmake/files/digest-pmake-1.45-r3
new file mode 100644
index 000000000000..110fde3e22d0
--- /dev/null
+++ b/sys-devel/pmake/files/digest-pmake-1.45-r3
@@ -0,0 +1 @@
+MD5 c0f21ad413abbb2fc76ec0d4d426578f pmake_1.45-11.tar.gz 252673
diff --git a/sys-devel/pmake/pmake-1.45-r3.ebuild b/sys-devel/pmake/pmake-1.45-r3.ebuild
new file mode 100644
index 000000000000..86a6dfb1dbac
--- /dev/null
+++ b/sys-devel/pmake/pmake-1.45-r3.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/pmake/pmake-1.45-r3.ebuild,v 1.1 2004/02/07 15:04:07 agriffis Exp $
+
+IUSE=""
+
+inherit eutils
+EPATCH_SOURCE="${FILESDIR}"
+EPATCH_SUFFIX="patch"
+
+DESCRIPTION="BSD build tool to create programs in parallel"
+HOMEPAGE="http://www.netbsd.org/"
+SRC_URI="mirror://gentoo/${PN}_${PV}-11.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="x86 alpha ia64 amd64"
+
+RDEPEND="virtual/glibc"
+DEPEND="${RDEPEND} >=sys-apps/sed-4"
+
+src_unpack() {
+ unpack ${A} && cd ${S} || die
+
+ # We do not want all patches in ${FILESDIR}, as 01_all_groffpatch.patch is
+ # not longer valid for this version.
+ epatch ${FILESDIR}/02_all_mktemp.patch
+
+ # Clean up headers to reduce warnings
+ sed -i -e 's|^#endif.*|#endif|' *.h */*.h
+}
+
+src_compile() {
+ local a=$ARCH
+ [[ $a = x86 ]] && a=i386
+
+ # The following CFLAGS are almost directly from Red Hat 8.0 and
+ # debian/rules, so assume it's okay to void out the __COPYRIGHT
+ # and __RCSID. I've checked the source and don't see the point,
+ # but whatever... (07 Feb 2004 agriffis)
+ CFLAGS="${CFLAGS} -Wall -D_GNU_SOURCE \
+ -D__COPYRIGHT\(x\)= -D__RCSID\(x\)= -I. \
+ -DMACHINE=\\\"gentoo\\\" -DMACHINE_ARCH=\\\"${a}\\\""
+ make -f Makefile.boot CFLAGS="${CFLAGS}"
+}
+
+src_install() {
+ dodir /usr/share/mk
+ insinto /usr/share/mk
+ rm -f mk/*~
+ doins mk/*
+
+ mv bmake pmake
+ dobin pmake
+ dobin mkdep
+ mv make.1 pmake.1
+ doman mkdep.1 pmake.1
+ dodoc PSD.doc/tutorial.ms
+}