summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-auth/pam_mount/pam_mount-0.49.ebuild')
-rw-r--r--sys-auth/pam_mount/pam_mount-0.49.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/sys-auth/pam_mount/pam_mount-0.49.ebuild b/sys-auth/pam_mount/pam_mount-0.49.ebuild
new file mode 100644
index 000000000000..d7c64f91f326
--- /dev/null
+++ b/sys-auth/pam_mount/pam_mount-0.49.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/pam_mount/pam_mount-0.49.ebuild,v 1.1 2008/10/09 16:53:20 hanno Exp $
+
+inherit multilib
+
+DESCRIPTION="A PAM module that can mount volumes for a user session"
+HOMEPAGE="http://pam-mount.sourceforge.net"
+SRC_URI="mirror://sourceforge/pam-mount/${P}.tar.lzma"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+IUSE="crypt"
+DEPEND=">=sys-libs/pam-0.72
+ dev-libs/openssl
+ >=sys-libs/libhx-1.25
+ dev-libs/libxml2
+ dev-util/pkgconfig"
+RDEPEND=">=sys-libs/pam-0.72
+ dev-libs/openssl
+ >=sys-libs/libhx-1.25
+ dev-libs/libxml2
+ >=sys-fs/cryptsetup-1.0.5
+ sys-process/lsof"
+
+src_compile() {
+ econf --with-slibdir="/$(get_libdir)" || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc doc/*.txt || die "dodoc failed"
+}