summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-misc/boinc')
-rw-r--r--sci-misc/boinc/ChangeLog5
-rw-r--r--sci-misc/boinc/files/boinc.init4
2 files changed, 7 insertions, 2 deletions
diff --git a/sci-misc/boinc/ChangeLog b/sci-misc/boinc/ChangeLog
index ad4c3f8d54be..346c869a1fc0 100644
--- a/sci-misc/boinc/ChangeLog
+++ b/sci-misc/boinc/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sci-misc/boinc
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-misc/boinc/ChangeLog,v 1.68 2009/07/29 11:48:31 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-misc/boinc/ChangeLog,v 1.69 2009/09/02 21:22:20 scarabeus Exp $
+
+ 02 Sep 2009; Tomáš Chvátal <scarabeus@gentoo.org> files/boinc.init:
+ Fix attach function. Per bug #266684.
29 Jul 2009; Tomáš Chvátal <scarabeus@gentoo.org>
+files/6.4.5-glibc210.patch, boinc-6.4.5-r2.ebuild:
diff --git a/sci-misc/boinc/files/boinc.init b/sci-misc/boinc/files/boinc.init
index efa7355f10c3..b66da328a69c 100644
--- a/sci-misc/boinc/files/boinc.init
+++ b/sci-misc/boinc/files/boinc.init
@@ -108,7 +108,9 @@ attach() {
# we have to work in runtime directory
cd "${RUNTIMEDIR}"
# boinc does not return 1 when it fails currently
- "${BOINCBIN}" --chuid "${USER}:${GROUP}" --attach_project "${url}" "${key}" &> /dev/null
+ "${BOINCBIN}" --attach_project "${url}" "${key}" &> /dev/null
+ # change the perms for the files to defined user/group
+ chown -R ${USER}:${GROUP} *
eend $?
sleep 10