summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/octave/ChangeLog8
-rw-r--r--sci-mathematics/octave/Manifest20
-rw-r--r--sci-mathematics/octave/files/digest-octave-2.1.71-r11
-rw-r--r--sci-mathematics/octave/octave-2.1.71-r1.ebuild106
-rw-r--r--sci-mathematics/scilab/ChangeLog8
-rw-r--r--sci-mathematics/scilab/Manifest2
-rw-r--r--sci-mathematics/scilab/files/digest-scilab-3.1.1-r31
-rw-r--r--sci-mathematics/scilab/scilab-3.1.1-r3.ebuild186
8 files changed, 316 insertions, 16 deletions
diff --git a/sci-mathematics/octave/ChangeLog b/sci-mathematics/octave/ChangeLog
index 9d30e0c53908..b6c70b197d3e 100644
--- a/sci-mathematics/octave/ChangeLog
+++ b/sci-mathematics/octave/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-mathematics/octave
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/octave/ChangeLog,v 1.15 2005/10/22 23:39:18 cryos Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/octave/ChangeLog,v 1.16 2005/11/13 05:34:47 ribosome Exp $
+
+*octave-2.1.71-r1 (13 Nov 2005)
+
+ 13 Nov 2005; Olivier Fisette <ribosome@gentoo.org>
+ +octave-2.1.71-r1.ebuild:
+ Migrated to fortran.eclass (bug #65950).
22 Oct 2005; Marcus D. Hanwell <cryos@gentoo.org> octave-2.1.71.ebuild:
Allow the use of gfortran too for gcc4, closes bug 108781.
diff --git a/sci-mathematics/octave/Manifest b/sci-mathematics/octave/Manifest
index 33b5634ff19e..4b725b268909 100644
--- a/sci-mathematics/octave/Manifest
+++ b/sci-mathematics/octave/Manifest
@@ -1,18 +1,10 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
+MD5 e7a66fad5a451fe4a902ee91bc6cd6a2 octave-2.1.71.ebuild 3546
+MD5 bd2ed4dec06725b62ae2a8d1f97c196e octave-2.1.69.ebuild 3633
+MD5 a5c02c7b4515b17aabf5485f4e12e11f octave-2.1.71-r1.ebuild 3420
+MD5 62c4dfb1220dccc6624875121b80bbeb octave-2.1.57-r1.ebuild 3668
MD5 2232e441020ce9244f94361292546063 ChangeLog 8858
+MD5 8c623e53daafa025137077c6b65815bd metadata.xml 156
MD5 32c6cee1f5b42b8b20369c3722fb4db2 files/digest-octave-2.1.57-r1 67
+MD5 6582a298022b4c4301eca44791cb6da2 files/digest-octave-2.1.71-r1 67
MD5 67d13a7bca35d1d0210394b7735fd073 files/digest-octave-2.1.69 67
MD5 6582a298022b4c4301eca44791cb6da2 files/digest-octave-2.1.71 67
-MD5 8c623e53daafa025137077c6b65815bd metadata.xml 156
-MD5 62c4dfb1220dccc6624875121b80bbeb octave-2.1.57-r1.ebuild 3668
-MD5 bd2ed4dec06725b62ae2a8d1f97c196e octave-2.1.69.ebuild 3633
-MD5 e7a66fad5a451fe4a902ee91bc6cd6a2 octave-2.1.71.ebuild 3546
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.4.1 (GNU/Linux)
-
-iD8DBQFDWs2zntT9W3vfTuoRAkYLAJ0aeLBu1GIIgbOhY9h599U9qAdPUwCfReNY
-D+uAUjecAU5t9ftz8RRH3sc=
-=moQ0
------END PGP SIGNATURE-----
diff --git a/sci-mathematics/octave/files/digest-octave-2.1.71-r1 b/sci-mathematics/octave/files/digest-octave-2.1.71-r1
new file mode 100644
index 000000000000..c5707c297b65
--- /dev/null
+++ b/sci-mathematics/octave/files/digest-octave-2.1.71-r1
@@ -0,0 +1 @@
+MD5 2ab06912017c833549035111f0ab592f octave-2.1.71.tar.bz2 5784751
diff --git a/sci-mathematics/octave/octave-2.1.71-r1.ebuild b/sci-mathematics/octave/octave-2.1.71-r1.ebuild
new file mode 100644
index 000000000000..4acbf5d20281
--- /dev/null
+++ b/sci-mathematics/octave/octave-2.1.71-r1.ebuild
@@ -0,0 +1,106 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/octave/octave-2.1.71-r1.ebuild,v 1.1 2005/11/13 05:34:47 ribosome Exp $
+
+inherit flag-o-matic fortran
+
+DESCRIPTION="GNU Octave is a high-level language (MatLab compatible) intended for numerical computations"
+LICENSE="GPL-2"
+HOMEPAGE="http://www.octave.org/"
+SRC_URI="ftp://ftp.octave.org/pub/octave/bleeding-edge/${P}.tar.bz2
+ ftp://ftp.math.uni-hamburg.de/pub/soft/math/octave/${P}.tar.bz2"
+
+SLOT="0"
+IUSE="emacs static readline zlib tetex hdf5 mpi ifc blas"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+
+DEPEND="virtual/libc
+ >=sys-libs/ncurses-5.2-r3
+ >=media-gfx/gnuplot-3.7.1-r3
+ >=sci-libs/fftw-2.1.3
+ >=dev-util/gperf-2.7.2
+ zlib? ( sys-libs/zlib )
+ hdf5? ( sci-libs/hdf5 )
+ tetex? ( virtual/tetex )
+ x86? ( ifc? ( dev-lang/ifc ) )
+ blas? ( virtual/blas )
+ !=app-text/texi2html-1.70"
+
+# NOTE: octave supports blas/lapack from intel but this is not open
+# source nor is it free (as in beer OR speech) Check out...
+# http://developer.intel.com/software/products/mkl/mkl52/index.htm for
+# more information
+
+src_compile() {
+ filter-flags -ffast-math
+
+ local myconf="--localstatedir=/var/state/octave --enable-rpath"
+ myconf="${myconf} --enable-lite-kernel"
+ use static || myconf="${myconf} --disable-static --enable-shared --enable-dl"
+ # Only add -lz to LDFLAGS if we have zlib in USE !
+ # BUG #52604
+ # Danny van Dyk 2004/08/26
+ use zlib && LDFLAGS="${LDFLAGS} -lz"
+
+ econf \
+ $(use_with hdf5) \
+ $(use_with mpi) \
+ $(use_enable readline) \
+ ${myconf} \
+ LDFLAGS="${LDFLAGS}" || die "econf failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ make install DESTDIR="${D}" || die "make install failed"
+ if use tetex; then
+ octave-install-doc || die "Octave doc install failed"
+ fi
+ if use emacs; then
+ cd emacs
+ exeinto /usr/bin
+ doexe otags || die
+ doman otags.1 || die
+ for emacsdir in /usr/share/emacs/site-lisp /usr/lib/xemacs/site-lisp; do
+ insinto ${emacsdir}
+ doins *.el || die
+ done
+ cd ..
+ fi
+ dodir /etc/env.d || die
+ echo "LDPATH=/usr/lib/octave-${PV}" > "${D}"/etc/env.d/99octave || die
+
+ # Fixes ls-R files to remove /var/tmp/portage references.
+ sed -i -e "s:${D}::g" "${D}"/usr/libexec/${PN}/ls-R || die
+ sed -i -e "s:${D}::g" "${D}"/usr/share/${PN}/ls-R || die
+}
+
+pkg_postinst() {
+ echo
+ einfo "Some users have reported failures at running simple tests if"
+ einfo "octave was built with agressive optimisations. You can check if"
+ einfo "your setup is affected by this bug by running the following test"
+ einfo "(inside the octave interpreter):"
+ einfo
+ einfo "octave:1> y = [1 3 4 2 1 5 3 5 6 7 4 5 7 10 11 3];"
+ einfo "octave:2> g = [1 1 1 1 1 1 1 1 2 2 2 2 2 3 3 3];"
+ einfo "octave:3> anova(y, g)"
+ einfo
+ einfo "If these commands complete successfully with no error message,"
+ einfo "your installation should be ok. Otherwise, try recompiling"
+ einfo "octave using less agressive \"CFLAGS\" (combining \"-O3\" and"
+ einfo "\"-march=pentium4\" is known to cause problems)."
+ echo
+}
+
+octave-install-doc() {
+ echo "Installing documentation..."
+ insinto /usr/share/doc/${PF}
+ doins doc/faq/Octave-FAQ.dvi || die
+ doins doc/interpreter/octave.dvi || die
+ doins doc/liboctave/liboctave.dvi || die
+ doins doc/refcard/refcard-a4.dvi || die
+ doins doc/refcard/refcard-legal.dvi || die
+ doins doc/refcard/refcard-letter.dvi || die
+}
diff --git a/sci-mathematics/scilab/ChangeLog b/sci-mathematics/scilab/ChangeLog
index e58925997d4b..f1ae7fe69216 100644
--- a/sci-mathematics/scilab/ChangeLog
+++ b/sci-mathematics/scilab/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-mathematics/scilab
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/scilab/ChangeLog,v 1.13 2005/10/01 18:53:19 ribosome Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/scilab/ChangeLog,v 1.14 2005/11/13 05:36:47 ribosome Exp $
+
+*scilab-3.1.1-r3 (13 Nov 2005)
+
+ 13 Nov 2005; Olivier Fisette <ribosome@gentoo.org>
+ +scilab-3.1.1-r3.ebuild:
+ Migrated to fortran.eclass (bug #65950).
*scilab-3.1.1-r2 (01 Oct 2005)
diff --git a/sci-mathematics/scilab/Manifest b/sci-mathematics/scilab/Manifest
index e245f761fd5c..3de1974bb482 100644
--- a/sci-mathematics/scilab/Manifest
+++ b/sci-mathematics/scilab/Manifest
@@ -4,8 +4,10 @@ MD5 40f7671ad69b1687f87850e710843f0d scilab-3.1.1-r2.ebuild 5808
MD5 98a93c775c31d389443fdbb685449d81 scilab-3.1.1-r1.ebuild 5942
MD5 703e496aef9cf567eb1fd7c43443846d ChangeLog 5766
MD5 8c623e53daafa025137077c6b65815bd metadata.xml 156
+MD5 e185265565e1f9652509a0247dbc5842 scilab-3.1.1-r3.ebuild 4796
MD5 bbe608fb3f1804163b4b8af882c8dcbb files/digest-scilab-3.1.1-r1 70
MD5 bbe608fb3f1804163b4b8af882c8dcbb files/digest-scilab-3.1.1-r2 70
+MD5 bbe608fb3f1804163b4b8af882c8dcbb files/digest-scilab-3.1.1-r3 70
MD5 814dd511c89a14982a5d6c60b09c1709 files/scilab-2.7-configure.patch 1702
MD5 f8e77491ef5140fe63fbe21ca1964377 files/digest-scilab-2.7-r3 135
MD5 bbe608fb3f1804163b4b8af882c8dcbb files/digest-scilab-3.1.1 70
diff --git a/sci-mathematics/scilab/files/digest-scilab-3.1.1-r3 b/sci-mathematics/scilab/files/digest-scilab-3.1.1-r3
new file mode 100644
index 000000000000..4cebd839d0d2
--- /dev/null
+++ b/sci-mathematics/scilab/files/digest-scilab-3.1.1-r3
@@ -0,0 +1 @@
+MD5 8bd6e750681fc6b2f524b46876dc0887 scilab-3.1.1-src.tar.gz 14261772
diff --git a/sci-mathematics/scilab/scilab-3.1.1-r3.ebuild b/sci-mathematics/scilab/scilab-3.1.1-r3.ebuild
new file mode 100644
index 000000000000..b05dafeea9e7
--- /dev/null
+++ b/sci-mathematics/scilab/scilab-3.1.1-r3.ebuild
@@ -0,0 +1,186 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/scilab/scilab-3.1.1-r3.ebuild,v 1.1 2005/11/13 05:36:47 ribosome Exp $
+
+inherit eutils fortran
+
+DESCRIPTION="Scientific software package for numerical computations (Matlab lookalike)"
+LICENSE="scilab"
+SRC_URI="http://scilabsoft.inria.fr/download/stable/${P}-src.tar.gz"
+HOMEPAGE="http://www.scilab.org/"
+
+SLOT="0"
+IUSE="ifc ocaml tcltk gtk Xaw3d"
+KEYWORDS="~x86 ~ppc"
+
+RDEPEND="virtual/x11
+ virtual/blas
+ virtual/lapack
+ sys-libs/ncurses
+ gtk? (
+ media-libs/jpeg
+ media-libs/libpng
+ sys-libs/zlib
+ >=x11-libs/gtk+-2
+ >=x11-libs/libzvt-2
+ =gnome-extra/libgtkhtml-2*
+ )
+ tcltk? ( >=dev-lang/tk-8.4
+ >=dev-lang/tcl-8.4 )
+ Xaw3d? ( x11-libs/Xaw3d )
+ ocaml? ( dev-lang/ocaml )"
+
+DEPEND="${RDEPEND}
+ ifc? ( dev-lang/ifc )
+ app-text/sablotron"
+
+pkg_setup() {
+ need_fortran g77
+ if ! use gtk && ! use tcltk; then
+ echo
+ eerror 'scilab must be built with either USE="gtk" or USE="tcltk"'
+ die
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ sed -i \
+ -e '/^ATLAS_LAPACKBLAS\>/s,=.*,= $(ATLASDIR)/liblapack.so $(ATLASDIR)/libblas.so $(ATLASDIR)/libcblas.so,' \
+ -e 's,$(SCIDIR)/libs/lapack.a,,' \
+ Makefile.OBJ.in
+
+ # fix scilab script causing problems (#67905)
+ # epatch ${FILESDIR}/${P}-initialization.patch
+}
+
+src_compile() {
+ local myopts
+ use tcltk || myopts="${myopts} --without-tk"
+ use Xaw3d || myopts="${myopts} --without-xaw3d"
+ myopts="${myopts} --with-atlas-library=/usr/lib"
+ if use gtk; then
+ myopts="${myopts} --with-gtk2"
+ fi
+ if ! use ocaml; then
+ myopts="${myopts} --without-ocaml"
+ fi
+
+ econf ${myopts} || die
+ env HOME="${S}" make all || die
+}
+
+src_install() {
+ # These instructions come from the file ${P}/Makefile, mostly section
+ # install. Make sure files have not been removed or added to these list
+ # when you use this ebuild as a template for future versions.
+ PVMBINDISTFILES="\
+ ${P}/pvm3/Readme \
+ ${P}/pvm3/lib/pvm \
+ ${P}/pvm3/lib/pvmd \
+ ${P}/pvm3/lib/pvmtmparch \
+ ${P}/pvm3/lib/pvmgetarch \
+ ${P}/pvm3/lib/LINUX/pvmd3 \
+ ${P}/pvm3/lib/LINUX/pvmgs \
+ ${P}/pvm3/lib/LINUX/pvm \
+ ${P}/pvm3/bin/LINUX/*"
+ BINDISTFILES="\
+ ${P}/.binary \
+ ${P}/.pvmd.conf \
+ ${P}/ACKNOWLEDGEMENTS \
+ ${P}/CHANGES \
+ ${P}/Makefile \
+ ${P}/Makefile.OBJ \
+ ${P}/Makefile.incl \
+ ${P}/Makemex \
+ ${P}/Path.incl \
+ ${P}/README_Unix \
+ ${P}/Version.incl \
+ ${P}/configure \
+ ${P}/libtool \
+ ${P}/license.txt \
+ ${P}/licence.txt \
+ ${P}/scilab.quit \
+ ${P}/scilab.star \
+ ${P}/X11_defaults \
+ ${P}/bin \
+ ${P}/config \
+ ${P}/contrib \
+ ${P}/demos \
+ ${P}/examples \
+ ${P}/imp/NperiPos.ps \
+ ${P}/imp/giffonts \
+ ${P}/macros \
+ ${P}/man/eng/ \
+ ${P}/man/fr/ \
+ ${P}/man/*.dtd \
+ ${P}/man/*/*.xsl \
+ ${P}/maple \
+ ${P}/routines/*.h \
+ ${P}/routines/Make.lib \
+ ${P}/routines/default/FCreate \
+ ${P}/routines/default/Flist \
+ ${P}/routines/default/README \
+ ${P}/routines/default/fundef \
+ ${P}/routines/default/*.c \
+ ${P}/routines/default/*.f \
+ ${P}/routines/default/*.h \
+ ${P}/routines/graphics/Math.h \
+ ${P}/routines/graphics/Graphics.h \
+ ${P}/routines/graphics/Entities.h \
+ ${P}/routines/interf/*.h \
+ ${P}/routines/intersci/sparse.h \
+ ${P}/routines/menusX/*.h \
+ ${P}/routines/scicos/scicos.h \
+ ${P}/routines/scicos/scicos_block.h \
+ ${P}/routines/sun/*.h \
+ ${P}/routines/xsci/*.h \
+ ${P}/scripts \
+ ${P}/tcl \
+ ${P}/tests \
+ ${P}/util"
+
+ touch .binary
+ strip bin/scilex
+ cd "${S}"/tests && make distclean
+ cd "${S}"/examples && make distclean
+ cd "${S}"/man && make man
+
+ dodir /usr/lib
+ (cd "${S}"/.. && tar cf - ${BINDISTFILES} ${PVMBINDISTFILES} | (cd "${D}"/usr/lib; tar xf -))
+ rm .binary
+
+ dodir /usr/bin
+ dosym /usr/lib/${P}/bin/scilab /usr/bin/scilab
+ dosym /usr/lib/${P}/bin/intersci /usr/bin/intersci
+ dosym /usr/lib/${P}/bin/intersci-n /usr/bin/intersci-n
+
+ # The compile and install process causes the work folder to be registered
+ # as the runtime folder in many files. This is corrected here.
+ BAD_REF="${WORKDIR}/${P}"
+ FIXED_REF="/usr/lib/${P}"
+ BIN_TO_FIX="Blpr BEpsf Blatexpr2 Blatexprs Blatexpr scilab"
+ for i in ${BIN_TO_FIX}; do
+ sed -e "s%${BAD_REF}%${FIXED_REF}%" -i "${D}"/usr/lib/${P}/bin/${i} \
+ || die
+ done
+ MAN_TO_FIX="eng fr"
+ for i in ${MAN_TO_FIX}; do
+ for j in "${D}"/usr/lib/${P}/man/${i}/*.h*; do
+ sed -e "s%${BAD_REF}%${FIXED_REF}%" -i ${j} || die
+ done
+ done
+ MISC_TO_FIX="util/Blatdoc util/Blatdocs"
+ for i in ${MISC_TO_FIX}; do
+ sed -e "s%${BAD_REF}%${FIXED_REF}%" -i "${D}"/usr/lib/${P}/${i} || die
+ done
+}
+
+pkg_postinst() {
+ einfo "To tell Scilab about your printers, set the environment"
+ einfo "variable PRINTERS in the form:"
+ einfo
+ einfo "PRINTERS=\"firstPrinter:secondPrinter:anotherPrinter\""
+}