summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-mathematics/ksimus-floatingpoint/ksimus-floatingpoint-0.3.6.ebuild')
-rw-r--r--sci-mathematics/ksimus-floatingpoint/ksimus-floatingpoint-0.3.6.ebuild20
1 files changed, 15 insertions, 5 deletions
diff --git a/sci-mathematics/ksimus-floatingpoint/ksimus-floatingpoint-0.3.6.ebuild b/sci-mathematics/ksimus-floatingpoint/ksimus-floatingpoint-0.3.6.ebuild
index 2f8bf8611798..c132f6e69c7e 100644
--- a/sci-mathematics/ksimus-floatingpoint/ksimus-floatingpoint-0.3.6.ebuild
+++ b/sci-mathematics/ksimus-floatingpoint/ksimus-floatingpoint-0.3.6.ebuild
@@ -1,13 +1,16 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/ksimus-floatingpoint/ksimus-floatingpoint-0.3.6.ebuild,v 1.1 2004/12/28 15:29:51 ribosome Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/ksimus-floatingpoint/ksimus-floatingpoint-0.3.6.ebuild,v 1.2 2005/05/27 11:51:25 phosphan Exp $
-inherit kde
+inherit kde eutils
-DESCRIPTION="The package Floating Point contains some floating point related components for KSimus."
+MYPATCH="${PN}-${PV}-namespaces.patch"
HOMEPAGE="http://ksimus.berlios.de/"
+DESCRIPTION="The package Floating Point contains some floating point related components for KSimus."
KEYWORDS="x86"
-SRC_URI="http://ksimus.berlios.de/download/ksimus-floatingpoint-3-${PV}.tar.gz"
+SRC_URI="http://ksimus.berlios.de/download/${PN}-3-${PV}.tar.gz
+ mirror://gentoo/${MYPATCH}.bz2
+ http://dev.gentoo.org/~phosphan/${MYPATCH}.bz2"
LICENSE="GPL-2"
IUSE=""
@@ -16,3 +19,10 @@ SLOT="0"
DEPEND="sci-mathematics/ksimus"
need-kde 3
+
+src_unpack() {
+ unpack ${A}
+ unpack ${MYPATCH}.bz2
+ cd ${S}
+ epatch ${WORKDIR}/${MYPATCH}
+}