summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-geosciences/viking/viking-1.2.1.ebuild')
-rw-r--r--sci-geosciences/viking/viking-1.2.1.ebuild10
1 files changed, 8 insertions, 2 deletions
diff --git a/sci-geosciences/viking/viking-1.2.1.ebuild b/sci-geosciences/viking/viking-1.2.1.ebuild
index b88a33bff678..7ea7568bf528 100644
--- a/sci-geosciences/viking/viking-1.2.1.ebuild
+++ b/sci-geosciences/viking/viking-1.2.1.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/viking/viking-1.2.1.ebuild,v 1.1 2011/06/17 08:43:45 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/viking/viking-1.2.1.ebuild,v 1.2 2011/06/17 19:47:45 scarabeus Exp $
EAPI=4
-inherit base
+inherit base autotools
DESCRIPTION="GPS data editor and analyzer"
HOMEPAGE="http://viking.sourceforge.net/"
@@ -38,8 +38,14 @@ DOCS=( README doc/GEOCODED-PHOTOS doc/GETTING-STARTED doc/GPSMAPPER )
PATCHES=(
"${FILESDIR}"/${PN}-gpsd-2.96.patch
+ "${FILESDIR}"/${PV}-autoreconf.patch
)
+src_prepare() {
+ base_src_prepare
+ eautoreconf
+}
+
src_configure() {
econf \
--disable-deprecations \