summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-chemistry/probe/probe-2.12.071128.ebuild')
-rw-r--r--sci-chemistry/probe/probe-2.12.071128.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/sci-chemistry/probe/probe-2.12.071128.ebuild b/sci-chemistry/probe/probe-2.12.071128.ebuild
new file mode 100644
index 000000000000..be8071b4c135
--- /dev/null
+++ b/sci-chemistry/probe/probe-2.12.071128.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/probe/probe-2.12.071128.ebuild,v 1.1 2008/07/08 01:24:54 dberkholz Exp $
+
+inherit toolchain-funcs
+
+MY_P="${PN}.${PV}"
+DESCRIPTION="Evaluates atomic packing within or between molecules"
+HOMEPAGE="http://kinemage.biochem.duke.edu/software/probe.php"
+SRC_URI="http://kinemage.biochem.duke.edu/downloads/software/probe/${MY_P}.src.zip"
+LICENSE="richardson"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+RDEPEND=""
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+S="${WORKDIR}/${MY_P}.scr"
+
+src_unpack() {
+ unpack ${A}
+
+ # Respect CC
+ sed -i \
+ -e 's:cc:$(CC):g' \
+ ${S}/Makefile
+}
+
+src_compile() {
+ emake \
+ CC="$(tc-getCC)" \
+ CFLAGS="${CFLAGS}" \
+ MACHINEFLAGS="${LDFLAGS}" \
+ || die "make failed"
+}
+
+src_install() {
+ dobin ${S}/probe
+ dodoc ${S}/README*
+}