summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-biology/rebase/rebase-510.ebuild')
-rw-r--r--sci-biology/rebase/rebase-510.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/sci-biology/rebase/rebase-510.ebuild b/sci-biology/rebase/rebase-510.ebuild
new file mode 100644
index 000000000000..3eca62da9bbb
--- /dev/null
+++ b/sci-biology/rebase/rebase-510.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/rebase/rebase-510.ebuild,v 1.1 2005/10/06 01:51:00 ribosome Exp $
+
+DESCRIPTION="A restriction enzyme database"
+HOMEPAGE="http://rebase.neb.com"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+LICENSE="public-domain"
+
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~amd64 ~ppc-macos ~ppc64"
+IUSE="emboss minimal"
+# Minimal build keeps only the indexed files (if applicable) and the documentation.
+# The non-indexed database is not installed.
+
+DEPEND="emboss? ( sci-biology/emboss )"
+
+src_compile() {
+ if use emboss; then
+ echo
+ einfo "Indexing ${PN} for usage with EMBOSS."
+ mkdir REBASE
+ EMBOSS_DATA=. rebaseextract -auto -infile withrefm.${PV} \
+ -protofile proto.${PV} || die "Indexing ${PN} failed."
+ echo
+ fi
+}
+
+src_install() {
+ if ! use minimal; then
+ insinto /usr/share/${PN}
+ doins withrefm.${PV} proto.${PV}
+ fi
+ newdoc REBASE.DOC README
+ if use emboss; then
+ insinto /usr/share/EMBOSS/data/REBASE
+ doins REBASE/{embossre.enz,embossre.ref,embossre.sup}
+ fi
+}