summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-astronomy/orsa/orsa-0.7.0.ebuild')
-rw-r--r--sci-astronomy/orsa/orsa-0.7.0.ebuild25
1 files changed, 14 insertions, 11 deletions
diff --git a/sci-astronomy/orsa/orsa-0.7.0.ebuild b/sci-astronomy/orsa/orsa-0.7.0.ebuild
index 2b962c9800d9..a9b90d5ad179 100644
--- a/sci-astronomy/orsa/orsa-0.7.0.ebuild
+++ b/sci-astronomy/orsa/orsa-0.7.0.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/orsa/orsa-0.7.0.ebuild,v 1.1 2006/10/25 18:37:45 markusle Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/orsa/orsa-0.7.0.ebuild,v 1.2 2008/06/11 22:51:12 markusle Exp $
-inherit qt3 flag-o-matic
+inherit qt3 flag-o-matic multilib
DESCRIPTION="Celestial orbit reconstruction, simulation and analysis"
HOMEPAGE="http://orsa.sourceforge.net/"
@@ -10,7 +10,7 @@ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~x86 ~ppc"
+KEYWORDS="~x86 ~ppc ~amd64"
IUSE="opengl qt3 mpi ginac cln gsl fftw xinerama threads static"
DEPEND=">=sys-libs/readline-4.2
@@ -18,15 +18,16 @@ DEPEND=">=sys-libs/readline-4.2
fftw? ( =sci-libs/fftw-2.1* )
gsl? ( >=sci-libs/gsl-1.5 )
qt3? ( $(qt_min_version 3.3) )
- mpi? ( sys-cluster/lam-mpi )
+ mpi? ( sys-cluster/openmpi )
ginac? ( >=sci-mathematics/ginac-1.2.0 )
cln? ( >=sci-libs/cln-1.1.6 )"
src_unpack() {
unpack ${A}
- cd ${S}
+ cd "${S}"
epatch "${FILESDIR}"/${P}-gcc41.patch
epatch "${FILESDIR}"/${PN}-0.6.1-as-needed.patch
+ epatch "${FILESDIR}"/${P}-gcc4.3.patch
}
src_compile() {
@@ -35,12 +36,14 @@ src_compile() {
use ginac || myconf="--with-ginac-prefix=/no/such/file"
use gsl || myconf="${myconf} --with-gsl-prefix=/no/such/file"
use cln || myconf="${myconf} --with-cln-prefix=/no/such/file"
- use fftw || sed -i -e 's/have_fftw=yes/have_fftw=no/' configure \
- die "sed to fix fftw failed"
+ if use fftw; then
+ sed -i -e 's/have_fftw=yes/have_fftw=no/' configure \
+ || die "sed to fix fftw failed"
+ fi
use qt3 || myconf="${myconf} --with-qt-dir=/no/such/file"
if use mpi; then
- sed -e 's/\(orsa_LDADD = .*\)/\1 -llammpi++ -lmpi -llam -lpthread -lutil/' \
- -i src/orsa/Makefile || die "sed to fix MPI failed"
+ sed -e "s|\(orsa_LDADD = .*\)|\1 /usr/$(get_libdir)/libmpi.la /usr/$(get_libdir)/libmpi_cxx.la|" \
+ -i src/orsa/Makefile.in || die "sed to fix MPI failed"
fi
econf \
@@ -56,7 +59,7 @@ src_compile() {
}
src_install() {
- make DESTDIR=${D} install || die "make install failed"
+ make DESTDIR="${D}" install || die "make install failed"
dodoc AUTHORS COPYRIGHT DEVELOPERS TODO THANKS
insinto /usr/share/${P}/test
doins src/test/*.{cc,h,fft,ggo} || die "Failed to install tests"