summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-www/qplug')
-rw-r--r--net-www/qplug/ChangeLog8
-rw-r--r--net-www/qplug/files/digest-qplug-0.4.11
-rw-r--r--net-www/qplug/qplug-0.4.1.ebuild26
3 files changed, 35 insertions, 0 deletions
diff --git a/net-www/qplug/ChangeLog b/net-www/qplug/ChangeLog
new file mode 100644
index 000000000000..b8b99e3e157e
--- /dev/null
+++ b/net-www/qplug/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for net-www/qplug
+# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-www/qplug/ChangeLog,v 1.1 2003/08/03 20:57:15 vapier Exp $
+
+*qplug-0.4.1 (03 Aug 2003)
+
+ 03 Aug 2003; Mike Frysinger <vapier@gentoo.org> :
+ Initial import. Ebuild submitted by me.
diff --git a/net-www/qplug/files/digest-qplug-0.4.1 b/net-www/qplug/files/digest-qplug-0.4.1
new file mode 100644
index 000000000000..336bb5748a17
--- /dev/null
+++ b/net-www/qplug/files/digest-qplug-0.4.1
@@ -0,0 +1 @@
+MD5 e4cd5680b89395d013d08df19588f199 qplug-0.4.1.tgz 37139
diff --git a/net-www/qplug/qplug-0.4.1.ebuild b/net-www/qplug/qplug-0.4.1.ebuild
new file mode 100644
index 000000000000..8d1fd2e70b5f
--- /dev/null
+++ b/net-www/qplug/qplug-0.4.1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-www/qplug/qplug-0.4.1.ebuild,v 1.1 2003/08/03 20:57:15 vapier Exp $
+
+inherit nsplugins
+
+DESCRIPTION="Netscape plugin which gets basic informations from a QuakeWorld or Quake2 server"
+HOMEPAGE="http://www.linuxquake.com/qplug/"
+SRC_URI="http://www.linuxquake.com/qplug/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+
+DEPEND="virtual/x11"
+
+src_compile() {
+ emake OPTIMIZER="${CFLAGS}" || die
+}
+
+src_install() {
+ exeinto /opt/netscape/plugins
+ doexe qplug.so
+ inst_plugin /opt/netscape/plugins/qplug.so
+ dodoc Readme
+}