summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-www/middleman')
-rw-r--r--net-www/middleman/ChangeLog16
-rw-r--r--net-www/middleman/Manifest4
-rw-r--r--net-www/middleman/files/digest-middleman-1.91
-rw-r--r--net-www/middleman/middleman-1.9.ebuild73
4 files changed, 91 insertions, 3 deletions
diff --git a/net-www/middleman/ChangeLog b/net-www/middleman/ChangeLog
index f47217d4c032..15cf637826e4 100644
--- a/net-www/middleman/ChangeLog
+++ b/net-www/middleman/ChangeLog
@@ -1,6 +1,20 @@
# ChangeLog for net-www/middleman
# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/middleman/ChangeLog,v 1.3 2003/08/11 23:06:48 solar Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/middleman/ChangeLog,v 1.4 2003/09/11 14:36:50 solar Exp $
+
+*middleman-1.9 (11 Sep 2003)
+
+ 11 Sep 2003; <solar@gentoo.org> middleman-1.9.ebuild:
+ version bumpage, The changes in this release are as follows:
+ Support for ICP (Internet cache protocol) was added, making it
+ possible to arrange several proxies in a hierarchy and share cached
+ objects. It is now possible to specify multiple directories for
+ cached objects to be stored. The 'Host' and 'File' options in most
+ configuration sections were removed in favor of enabling/ disable
+ profiles based on the URL requested. A workaround was added for a
+ bug triggered by improper headers sent by Apache 1.3 when a tar.gz
+ file was requested by a client that doesn't support gzip
+ compression.
*middleman-1.8.2 (11 Aug 2003)
diff --git a/net-www/middleman/Manifest b/net-www/middleman/Manifest
index 72c4f81dcf82..f13814b9d8e4 100644
--- a/net-www/middleman/Manifest
+++ b/net-www/middleman/Manifest
@@ -1,8 +1,8 @@
-MD5 9926208017470f911332ba3da4af2ef4 ChangeLog 1384
+MD5 da66ba8e9bd085989f4e556516f27e6d ChangeLog 1384
MD5 b3089a22f33a39676bb267f8d3d59c07 metadata.xml 1012
MD5 dd7e12e9d59a0ac5bb04773c3ccefe45 middleman-1.8.1.ebuild 1646
MD5 d63dbeb786cd6bde6e01db58bfb71776 middleman-1.8.2.ebuild 1646
-MD5 f84a9443c490a15c9f5509103e886d50 middleman-1.9.ebuild 1879
+MD5 e20fcd9fb500f640eff05a82aad7b779 middleman-1.9.ebuild 1874
MD5 f310f39bd53b2a586b1f6ae1755dd09c files/digest-middleman-1.8.1 67
MD5 118e1d1a342e3e7faeb0cf43391f6aea files/digest-middleman-1.8.2 67
MD5 6603f0878f141095d688dd36c760a878 files/digest-middleman-1.9 65
diff --git a/net-www/middleman/files/digest-middleman-1.9 b/net-www/middleman/files/digest-middleman-1.9
new file mode 100644
index 000000000000..73d683dd87c3
--- /dev/null
+++ b/net-www/middleman/files/digest-middleman-1.9
@@ -0,0 +1 @@
+MD5 235302e462d9dfe833e9484d445089bf middleman-1.9.tar.gz 624685
diff --git a/net-www/middleman/middleman-1.9.ebuild b/net-www/middleman/middleman-1.9.ebuild
new file mode 100644
index 000000000000..acc704cc5c67
--- /dev/null
+++ b/net-www/middleman/middleman-1.9.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-www/middleman/middleman-1.9.ebuild,v 1.1 2003/09/11 14:36:50 solar Exp $
+
+inherit eutils
+
+DESCRIPTION="Advanced HTTP/1.1 proxy server with features designed to increase privacy and remove unwanted content"
+SRC_URI="mirror://sourceforge/middle-man/${P}.tar.gz"
+HOMEPAGE="http://sourceforge.net/projects/middle-man"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="${IUSE} pam zlib"
+
+S=${WORKDIR}/${PN}
+
+DEPEND="virtual/glibc
+ dev-libs/libpcre
+ pam? ( sys-libs/pam )
+ zlib? ( sys-libs/zlib )
+"
+
+src_unpack() {
+ unpack ${A}
+ [ -f ${FILESDIR}/${P}-gentoo.diff ] && epatch ${FILESDIR}/${P}-gentoo.diff
+ cd ${S}
+ if [ "$PV" = "1.9" ]; then
+ einfo "Patching Makefile.in to avoid sanbox problems"
+ sed -e s:"INSTALL) -d /var":"INSTALL) -d \$(DESTDIR)/var":g < Makefile.in > Makefile.out && mv Makefile.{out,in}
+ fi
+}
+
+src_compile() {
+ local myconf=""
+ MAKEOPTS="-j1"
+
+ cd ${S}
+ for opt in ${IUSE}; do
+ use ${opt} &&
+ myconf="${myconf} --enable-${opt}" ||
+ myconf="$myconf --disable-${opt}"
+ done
+
+ econf --sysconfdir=/etc/mman ${myconf} || die "econf failed: ${myconf}"
+ emake || die "emake failed"
+}
+
+src_install() {
+ cd ${S}
+ # mkdir -p ${D}/usr/share/man/man8/
+ make DESTDIR="${D}" install || die "einstall failed"
+
+ dodoc CHANGELOG COPYING
+ dohtml README.html
+
+ insinto /etc/conf.d
+ newins ${FILESDIR}/conf.d/mman mman
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/init.d/mman mman
+}
+
+#pkg_preinst() {
+# enewgroup mman 8080
+# enewuser mman 8080
+#}
+
+pkg_postinst() {
+ #einfo "A mman user has been added to your system if one did not already exist"
+ einfo "-"
+ einfo "Note: init/conf scripts and a sample config has been provided for you."
+ einfo "They can be found at or in /etc/conf.d/mman /etc/init.d/mman /etc/mman/"
+}