summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-wireless')
-rw-r--r--net-wireless/linux-wlan-ng/ChangeLog8
-rw-r--r--net-wireless/linux-wlan-ng/Manifest11
-rw-r--r--net-wireless/linux-wlan-ng/files/digest-linux-wlan-ng-0.2.21
-rw-r--r--net-wireless/linux-wlan-ng/files/linux-wlan-ng-gentoo-init97
-rw-r--r--net-wireless/linux-wlan-ng/linux-wlan-ng-0.2.2.ebuild154
5 files changed, 266 insertions, 5 deletions
diff --git a/net-wireless/linux-wlan-ng/ChangeLog b/net-wireless/linux-wlan-ng/ChangeLog
index 7f33c22403db..8715d2a0c169 100644
--- a/net-wireless/linux-wlan-ng/ChangeLog
+++ b/net-wireless/linux-wlan-ng/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-wireless/linux-wlan-ng
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-wireless/linux-wlan-ng/ChangeLog,v 1.49 2005/09/24 09:10:59 blubb Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/linux-wlan-ng/ChangeLog,v 1.50 2005/10/01 14:50:58 betelgeuse Exp $
+
+*linux-wlan-ng-0.2.2 (01 Oct 2005)
+
+ 01 Oct 2005; Petteri Räty <betelgeuse@gentoo.org>
+ +files/linux-wlan-ng-gentoo-init, +linux-wlan-ng-0.2.2.ebuild:
+ Version bump using the new splitted linux-wlan-ng ebuilds.
24 Sep 2005; Simon Stelling <blubb@gentoo.org>
linux-wlan-ng-0.2.1_pre23.ebuild:
diff --git a/net-wireless/linux-wlan-ng/Manifest b/net-wireless/linux-wlan-ng/Manifest
index 31112e620a26..d93a10f87aa3 100644
--- a/net-wireless/linux-wlan-ng/Manifest
+++ b/net-wireless/linux-wlan-ng/Manifest
@@ -1,9 +1,12 @@
-MD5 e91691a7c81c2bb8cca55526d7b0b003 ChangeLog 10256
-MD5 e67cea130653fc787a96bb81b00a6733 linux-wlan-ng-0.2.0-r3.ebuild 4752
-MD5 1d27e6e859600c0c1a310b3dbd11c274 linux-wlan-ng-0.2.1_pre20.ebuild 4254
MD5 d18b5a83fee6b963bc534d52f0d1dbf2 linux-wlan-ng-0.2.1_pre23.ebuild 3722
+MD5 1d27e6e859600c0c1a310b3dbd11c274 linux-wlan-ng-0.2.1_pre20.ebuild 4254
+MD5 eff1081a106e8083b0338730e0911d31 linux-wlan-ng-0.2.2.ebuild 3746
+MD5 e67cea130653fc787a96bb81b00a6733 linux-wlan-ng-0.2.0-r3.ebuild 4752
+MD5 e91691a7c81c2bb8cca55526d7b0b003 ChangeLog 10256
MD5 6ad1de0749fc3b426ff7f4f422d2484c metadata.xml 254
-MD5 296af9529b8492a5a12f1ba06d2a71de files/digest-linux-wlan-ng-0.2.0-r3 511
MD5 44bd75f98be313622f43eb03b494e125 files/digest-linux-wlan-ng-0.2.1_pre20 517
MD5 b11e06135cc8790abe78af54fa4fe95d files/digest-linux-wlan-ng-0.2.1_pre23 147
+MD5 f24842a9d1aeeaa901a2423011ef3b38 files/digest-linux-wlan-ng-0.2.2 72
+MD5 7fd052d0b20448622b9d05bd474f509b files/linux-wlan-ng-gentoo-init 1934
+MD5 296af9529b8492a5a12f1ba06d2a71de files/digest-linux-wlan-ng-0.2.0-r3 511
MD5 e2ca4c6c0bc3d8daef9ea0f822b88dca files/linux-wlan-2.6.10-fix.diff 3670
diff --git a/net-wireless/linux-wlan-ng/files/digest-linux-wlan-ng-0.2.2 b/net-wireless/linux-wlan-ng/files/digest-linux-wlan-ng-0.2.2
new file mode 100644
index 000000000000..5d45e8b8245e
--- /dev/null
+++ b/net-wireless/linux-wlan-ng/files/digest-linux-wlan-ng-0.2.2
@@ -0,0 +1 @@
+MD5 54b11244fa50a85b31f21c64a8f259b7 linux-wlan-ng-0.2.2.tar.bz2 458937
diff --git a/net-wireless/linux-wlan-ng/files/linux-wlan-ng-gentoo-init b/net-wireless/linux-wlan-ng/files/linux-wlan-ng-gentoo-init
new file mode 100644
index 000000000000..a4bf06ca734f
--- /dev/null
+++ b/net-wireless/linux-wlan-ng/files/linux-wlan-ng-gentoo-init
@@ -0,0 +1,97 @@
+#!/sbin/runscript
+
+source_config() {
+ if [ -f /etc/wlan/shared ]
+ then
+ source /etc/wlan/shared
+ else
+ return 1
+ fi
+ return 0
+}
+
+start() {
+ ebegin "Starting WLAN devices"
+ if ! source_config
+ then
+ eerror "Error loading /etc/wlan/shared"
+ eend 1
+ return 1
+ fi
+
+ # NOTE: We don't explicitly insmod the card driver here. The
+ # best thing to do is to specify an alias in /etc/modules.conf.
+ # Then, the first time we call wlanctl with the named device,
+ # the kernel module autoload stuff will take over.
+
+ for DEVICE in $WLAN_DEVICES; do
+ #=======ENABLE========================================
+ # Do we want to init the card at all?
+ eval 'WLAN_ENABLE=$ENABLE_'$DEVICE
+ if ! is_true $WLAN_ENABLE ; then
+ continue
+ fi
+
+ if is_true $WLAN_DOWNLOAD; then
+ wlan_download $DEVICE
+ fi
+
+ wlan_enable $DEVICE
+
+ #=======MAC STARTUP=========================================
+ wlan_supports_scan $DEVICE
+
+ if [ $? = 0 ] ; then
+ wlan_scan $DEVICE
+ if [ $? = 0 ] ; then
+ wlan_source_config_for_ssid "$ssid" "$bssid"
+
+ wlan_user_mibs $DEVICE
+ # make it quiet
+ error=`eval wlan_wep $DEVICE`
+
+ grep 'autojoin' /proc/net/p80211/$DEVICE/wlandev > /dev/null
+ if [ $? = 0 ]; then
+ wlan_infra $DEVICE
+ else
+ wlan_dot11_join $DEVICE
+ fi
+ else
+ echo "network not found. maybe start IBSS?"
+ fi
+ else
+ wlan_source_config $DEVICE
+
+ wlan_user_mibs $DEVICE
+ # make it quiet
+ error=`eval wlan_wep $DEVICE`
+
+ if is_true $IS_ADHOC ; then
+ wlan_adhoc $DEVICE
+ else
+ wlan_infra $DEVICE
+ fi
+ fi
+ done
+
+ eend 0
+}
+
+stop() {
+ ebegin "Shutting Down WLAN Devices"
+ if ! source_config
+ then
+ eerror "Error loading /etc/wlan/shared"
+ eend 1
+ return 1
+ fi
+
+ # Do a reset on each device to make sure none of them are still
+ # trying to generate interrupts.
+ for DEVICE in $WLAN_DEVICES; do
+ # This just makes it quiet...
+ error="$(eval wlan_disable $DEVICE)"
+ done
+
+ eend 0
+}
diff --git a/net-wireless/linux-wlan-ng/linux-wlan-ng-0.2.2.ebuild b/net-wireless/linux-wlan-ng/linux-wlan-ng-0.2.2.ebuild
new file mode 100644
index 000000000000..5bfea4e0c52a
--- /dev/null
+++ b/net-wireless/linux-wlan-ng/linux-wlan-ng-0.2.2.ebuild
@@ -0,0 +1,154 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/linux-wlan-ng/linux-wlan-ng-0.2.2.ebuild,v 1.1 2005/10/01 14:50:58 betelgeuse Exp $
+
+#The configure script needs prepared sources.
+inherit linux-mod
+
+DESCRIPTION="Programs/files needed for Prism2/2.5/3 based wireless LAN products"
+HOMEPAGE="http://linux-wlan.org"
+SRC_URI="ftp://ftp.linux-wlan.org/pub/linux-wlan-ng/${P}.tar.bz2"
+
+LICENSE="MPL-1.1"
+SLOT="0"
+KEYWORDS="~x86"
+
+IUSE="debug doc pcmcia"
+
+DEPEND="~net-wireless/linux-wlan-ng-modules-${PV}
+ ~net-wireless/linux-wlan-ng-utils-${PV}
+ ~net-wireless/linux-wlan-ng-firmware-${PV}"
+
+RDEPEND=${DEPEND}
+
+#relative to src/
+COMPILE_DIRS="mkmeta wlanctl wland nwepgen wlancfg prism2/download"
+INSTALL_DIRS="${COMPILE_DIRS} ../etc"
+
+CONFIG_FILE="${S}/default.config"
+CONFIG_DIR="/etc/conf.d"
+
+config_by_usevar() {
+ local config=${3}
+ [[ -z ${config} ]] && config=${CONFIG_FILE}
+
+ if use ${2}; then
+ echo "${1}=y" >> ${config}
+ else
+ echo "${1}=n" >> ${config}
+ fi
+}
+
+set_option() {
+ local config=${3}
+ [[ -z ${config} ]] && config=${CONFIG_FILE}
+
+ echo "${1}=${2}" >> ${config}
+}
+
+src_unpack() {
+ local config=${CONFIG_FILE}
+
+ unpack ${A}
+
+ rm ${S}/doc/rh71notes
+
+ cd ${S}/etc
+ mv rc.wlan rc.wlan.orig
+ cp ${FILESDIR}/${PN}-gentoo-init rc.wlan
+
+ #IMHO this should not be done but better to not upset users at this point
+ sed -i -e "s:/etc/wlan:/etc/conf.d:g" ${S}/etc/wlan/Makefile
+ sed -i -e "s:/etc/wlan/wlan.conf:/etc/conf.d/wlan.conf:g" \
+ -e "s:/etc/wlan/wlancfg:/etc/conf.d/wlancfg:g" \
+ ${S}/etc/wlan/shared
+
+ cp ${S}/config.in ${config}
+
+ set_option TARGET_ROOT_ON_HOST ${D}
+ set_option LINUX_SRC ${KERNEL_DIR}
+ set_option PRISM2_USB n
+ set_option PRISM2_PCI n
+ set_option PRISM2_PLX n
+ set_option PRISM2_PCMCIA n
+
+ if kernel_is gt 2 4; then
+ set_option KERN_25 y
+ fi
+
+ config_by_usevar WLAN_DEBUG debug
+}
+
+src_compile() {
+ set_arch_to_kernel
+ emake default_config || die "emake default_config failed"
+ set_arch_to_portage
+
+ CONFIG_FILE="config.mk"
+
+ set_option FIRMWARE_DIR "/lib/firmware"
+ config_by_usevar PRISM2_PCMCIA pcmcia
+
+ #For the scripts that go to /etc
+ set_option TARGET_PCMCIA_DIR ${D}/etc/pcmcia
+
+ cd ${S}/src/
+ for dir in ${COMPILE_DIRS}; do
+ pushd ${dir}
+ make || die "make in ${dir} failed"
+ popd
+ done
+}
+
+src_install() {
+ cd ${S}/man
+ doman *.1
+
+ for dir in ${INSTALL_DIRS}; do
+ pushd ${S}/src/${dir}
+ make install || die "make install in ${dir} failed"
+ popd
+ done
+
+ cd ${S}
+
+ dodir etc/wlan
+ mv ${D}/etc/conf.d/shared ${D}/etc/wlan/
+
+ if use doc; then
+ insinto /usr/share/doc/${PF}/
+ pushd ${S}/doc
+ for file in $(ls); do
+ [[ "${file}" != "Makefile" ]] && doins -r ${file}
+ done
+ popd
+ fi
+
+ dodoc CHANGES FAQ README THANKS TODO
+}
+
+pkg_postinst() {
+ einfo "/etc/init.d/wlan is used to control startup and shutdown of non-PCMCIA devices."
+ if use pcmcia; then
+ einfo "/etc/init.d/pcmcia from pcmcia-cs is used to control startup and shutdown of"
+ einfo "PCMCIA devices."
+ fi
+ einfo ""
+ einfo "Modify ${CONFIG_DIR}/wlan.conf to set global parameters."
+ einfo "Modify ${CONFIG_DIR}/wlancfg-* to set individual card parameters."
+ einfo "There are detailed instructions in these config files."
+ einfo ""
+ einfo "Three keygen programs are included: nwepgen, keygen, and lwepgen."
+ einfo "keygen seems provide more usable keys at the moment."
+ einfo "You can change the keygen in your wlancfg-* files."
+ einfo ""
+ einfo "Be sure to add iface_wlan0 parameters to /etc/conf.d/net."
+ einfo ""
+ if use pcmcia; then
+ ewarn "Wireless cards which you want to use drivers other than wlan-ng for"
+ ewarn "need to have the appropriate line removed from /etc/pcmcia/wlan-ng.conf"
+ ewarn "Do 'cardctl info' to see the manufacturer ID and remove the corresponding"
+ ewarn "line from that file."
+ fi
+}
+