summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-voip')
-rw-r--r--net-voip/telepathy-salut/ChangeLog6
-rw-r--r--net-voip/telepathy-salut/files/telepathy-salut-0.5.0-uninitialized.patch13
-rw-r--r--net-voip/telepathy-salut/telepathy-salut-0.5.0.ebuild10
3 files changed, 25 insertions, 4 deletions
diff --git a/net-voip/telepathy-salut/ChangeLog b/net-voip/telepathy-salut/ChangeLog
index 2768a38d0d2c..0305c1d1b081 100644
--- a/net-voip/telepathy-salut/ChangeLog
+++ b/net-voip/telepathy-salut/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-voip/telepathy-salut
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-voip/telepathy-salut/ChangeLog,v 1.19 2011/06/07 03:04:39 tester Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-voip/telepathy-salut/ChangeLog,v 1.20 2011/06/20 10:40:07 pacho Exp $
+
+ 20 Jun 2011; Pacho Ramos <pacho@gentoo.org> telepathy-salut-0.5.0.ebuild,
+ +files/telepathy-salut-0.5.0-uninitialized.patch:
+ Fix uninitialized variable and drop Werror, bug #369091 by Ed Catmur.
07 Jun 2011; Olivier Crête <tester@gentoo.org> telepathy-salut-0.5.0.ebuild:
xmldiff is alwasy required for the configure to pass
diff --git a/net-voip/telepathy-salut/files/telepathy-salut-0.5.0-uninitialized.patch b/net-voip/telepathy-salut/files/telepathy-salut-0.5.0-uninitialized.patch
new file mode 100644
index 000000000000..83723612dfc4
--- /dev/null
+++ b/net-voip/telepathy-salut/files/telepathy-salut-0.5.0-uninitialized.patch
@@ -0,0 +1,13 @@
+diff --git a/lib/ext/wocky/wocky/wocky-sasl-scram.c b/lib/ext/wocky/wocky/wocky-sasl-scram.c
+index 7261956..c508196 100644
+--- a/lib/ext/wocky/wocky/wocky-sasl-scram.c
++++ b/lib/ext/wocky/wocky/wocky-sasl-scram.c
+@@ -523,7 +523,7 @@ scram_handle_server_final_message (WockySaslScram *self,
+ gchar *message,
+ GError **error)
+ {
+- gchar attr, *value = NULL;
++ gchar attr = 0, *value = NULL;
+
+ if (!scram_get_next_attr_value (&message, &attr, &value) && attr != 'v')
+ goto invalid;
diff --git a/net-voip/telepathy-salut/telepathy-salut-0.5.0.ebuild b/net-voip/telepathy-salut/telepathy-salut-0.5.0.ebuild
index 492a2a1add1f..4f6ae7404e4d 100644
--- a/net-voip/telepathy-salut/telepathy-salut-0.5.0.ebuild
+++ b/net-voip/telepathy-salut/telepathy-salut-0.5.0.ebuild
@@ -1,11 +1,11 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-voip/telepathy-salut/telepathy-salut-0.5.0.ebuild,v 1.2 2011/06/07 03:04:39 tester Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-voip/telepathy-salut/telepathy-salut-0.5.0.ebuild,v 1.3 2011/06/20 10:40:07 pacho Exp $
EAPI="3"
PYTHON_DEPEND="2:2.5"
-inherit base python
+inherit base python eutils
DESCRIPTION="A link-local XMPP connection manager for Telepathy"
HOMEPAGE="http://telepathy.freedesktop.org/wiki/Components"
@@ -40,12 +40,16 @@ pkg_setup() {
}
src_prepare() {
+ # Fix uninitialized variable, upstream bug #37701
+ epatch "${FILESDIR}/${PN}-0.5.0-uninitialized.patch"
+
python_convert_shebangs -r 2 .
}
src_configure() {
econf \
- --disable-plugins
+ --disable-plugins \
+ --disable-Werror
#--docdir=/usr/share/doc/${PF}
#$(use_enable test avahi-tests)
}