summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-print/hplip/hplip-3.9.12-r1.ebuild')
-rw-r--r--net-print/hplip/hplip-3.9.12-r1.ebuild29
1 files changed, 10 insertions, 19 deletions
diff --git a/net-print/hplip/hplip-3.9.12-r1.ebuild b/net-print/hplip/hplip-3.9.12-r1.ebuild
index 7bfccd7450f1..24bfbdb06fe8 100644
--- a/net-print/hplip/hplip-3.9.12-r1.ebuild
+++ b/net-print/hplip/hplip-3.9.12-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-print/hplip/hplip-3.9.12-r1.ebuild,v 1.1 2010/01/02 19:38:07 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-print/hplip/hplip-3.9.12-r1.ebuild,v 1.2 2010/01/02 19:49:06 yngwin Exp $
EAPI=2
@@ -15,7 +15,7 @@ SLOT="0"
KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
# zeroconf does not work properly with >=cups-1.4. thus support for it is also disabled in hplip.
-IUSE="doc fax gtk +hpcups hpijs libnotify minimal -new-hpcups parport policykit qt3 qt4 scanner snmp static-ppds -udev-acl"
+IUSE="doc fax gtk +hpcups hpijs libnotify minimal -new-hpcups parport policykit qt4 scanner snmp static-ppds -udev-acl"
# Note : libusb-compat untested (calchan 20090516)
@@ -52,9 +52,6 @@ RDEPEND="${COMMON_DEPEND}
sys-apps/dbus
dev-python/dbus-python
)
- qt3? ( !qt4? (
- dev-python/PyQt
- ) )
qt4? (
dev-python/PyQt4[dbus,X]
dev-python/pygobject
@@ -71,7 +68,7 @@ CONFIG_CHECK="~PARPORT ~PPDEV"
ERROR_PARPORT="Please make sure parallel port support is enabled in your kernel (PARPORT and PPDEV)."
pkg_setup() {
- ! use qt3 && ! use qt4 && ewarn "You need USE=qt4 or USE=qt3 for the hplip GUI."
+ ! use qt4 && ewarn "You need USE=qt4 for the hplip GUI."
use scanner && ! use gtk && ewarn "You need USE=gtk for the scanner GUI."
@@ -133,9 +130,8 @@ src_prepare() {
done
local qt_ver
- if use qt3 || use qt4 ; then
- use qt3 && qt_ver="3"
- use qt4 && qt_ver="4"
+ if use qt4 ; then
+ qt_ver="4"
sed -i \
-e "s/%s --force-startup/%s --force-startup --qt${qt_ver}/" \
-e "s/'--force-startup'/'--force-startup', '--qt${qt_ver}'/" \
@@ -151,17 +147,12 @@ src_prepare() {
src_configure() {
local gui_build myconf drv_build minimal_build
- if use qt3 || use qt4 ; then
- gui_build="--enable-gui-build"
- if use qt4 ; then
- gui_build="${gui_build} --enable-qt4 --disable-qt3"
- if use policykit ; then
- myconf="--enable-policykit"
- else
- myconf="--disable-policykit"
- fi
+ if use qt4 ; then
+ gui_build="--enable-gui-build --enable-qt4 --disable-qt3"
+ if use policykit ; then
+ myconf="--enable-policykit"
else
- use qt3 && gui_build="${gui_build} --enable-qt3 --disable-qt4"
+ myconf="--disable-policykit"
fi
else
gui_build="--disable-gui-build --disable-qt3 --disable-qt4"